WordPress.org

Forums

Invite Anyone
[resolved] accept url gives 404 error (10 posts)

  1. mt78
    Member
    Posted 2 years ago #

    I have Buddypress 1.7 and just installed "invite anyone." I just sent an e-mail invite, which worked great. The link to my profile worked just fine, but the link to accept the invitation redirected to 404 error.

    Anyone else having this problem?

    http://wordpress.org/extend/plugins/invite-anyone/

  2. Boone Gorges
    Member
    Plugin Author

    Posted 2 years ago #

    What does the acceptance URL look like?

  3. mt78
    Member
    Posted 2 years ago #

    I can access the registration page just fine at:
    http://mydomain.com/registrace/

    However, this returns a 404:
    http://mydomain.com/signup/accept-invitation/invite2group%40milantucek.cz

    Thx

  4. Boone Gorges
    Member
    Plugin Author

    Posted 2 years ago #

    Can you verify whether the URL works when you replace the string 'signup' with 'registrace'?

  5. mt78
    Member
    Posted 2 years ago #

    I have replaced string signup and registration does working! How to fix it with registration page? Thx

  6. Boone Gorges
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for testing, mt78. I've found the bug, and I'll be releasing a new version of the plugin today that contains a fix. Please post back here once you've had a chance to test it.

  7. mt78
    Member
    Posted 2 years ago #

    Thank you very much plugin now working correctly!

  8. David Cavins
    Member
    Posted 2 years ago #

    Hi Boone-

    I'm having this problem, too. I'm using WP 3.5.1, BP 1.7.2, Invite Anyone 1.0.23. I've flushed the permalinks.

    The URL generated by the plugin looks like:
    http://blogurl.com/register/accept-invitation/address%40provider.com

    My site's registration URL is:
    http://blogurl.com/register

    In the settings, I've checked "Allow email invitations to be accepted even when site registration is disabled" and in WP > Settings > General, "Anyone can register" is checked.

    Any ideas? Thanks for your help.

    -David

  9. mt78
    Member
    Posted 1 year ago #

    Dear Boone, could you pls take a look at http://wordpress.org/support/topic/email-address-disappeared-from-the-invitation-link?replies=2 ?

    Invite anyone doesn't working.

    Two problems:
    1. Invites does work only when WP > Settings > General, "Anyone can register" is checked.

    2. email adress disappeared from the invitation link

    Thanks fo testing. I need your help asap please for my home page.

    Thanks a lot.

  10. fmatelli
    Member
    Posted 1 year ago #

    I was having the same issue and tried all I could find in the internet, but the solutions for my problem was very simples, I just forgot to associate the register and activate page on BP->Setting. Under the subsession 'Associate WordPress Pages with the following BuddyPress Registration pages'.

    Hope this could help someone.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Invite Anyone
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.