Support » Plugin: EU Cookie Law (GDPR) » Accept not working

  • Latest version does not close anymore with the button on certain sites we have. It reloads the page somehow. Ive noticed about dozen topics here but no solution. Is there one?

Viewing 15 replies - 1 through 15 (of 40 total)
  • I am getting the same

    Dear developers!
    Many have signaled this problem. Will this be a solution, or is it better if we are looking for another plugin?
    Regards!

    Same for me for latest version (3.0.1), no matter using Opera or Firefox. Is there a way to roll back to a previous version?

    • This reply was modified 1 year, 5 months ago by  funcoder88.

    Same problem !
    A new version please ?

    Same problem. It worked fine initially, but now, no matter what I change, the ACCEPT button does not work.

    Have you tried disabling your cache plugin(s)?

    @kevingrabner you are right !!!
    i was using a cache called vipercache. I updated it and even uptaded it is causing me an issue
    Without the plugin, the ACCEPT button works perfectly !
    Another paid plugin cache going directly to the trash !!! grrrrrrr

    I have disabled the cache (WP Fastest Cache) and it works, the fact that more than 1 plugin causes it to fail tells me the problem is with this plugin not the others, I think the only answer is to look for a new EU cookie law plugin that does work, the developer does not seem interested in fixing it or even acknowledging there is a problem.

    I give up. It seems that the plugin loads css to the footer and is somehow messing up jquery stuff so the button does not work.

    Any recommendations for others? GDPR Cookie Consent seemed smooth but didnt work with wpml string translations…

    I have the same problem and I tested without cache plugin and is not working either.
    Also I made a post a week ago and I’m still waiting for an answer.
    My luck that I have an older version that works with my live website but anyways we need a fix.

    For WP Super Cache User there is a Workaround that worked for me.
    I’m using the latest Versions of WP (4.9.6), WP Super Cache (1.6.1) and EU Cookie Law (3.0.1)

    This is a Quote from the FAQ:

    We are working to improve cache compatibility. As for now, conflicts may occur.

    WP Super Cache (sperimental*): open the file wp-content/advanced-cache.php and add the following immediately after <?php opening:
    if ( !isset( $_COOKIE[‚euCookie‘] ) ){ return; }

    So that you have:
    <?php
    if ( !isset( $_COOKIE[‚euCookie‘] ) ){ return; }
    function wpcache_broken_message() {

    Important Notice!
    It seemed that the editing of this file get overritten when you flush the Cache!
    Maybe someone has a better idea where you can place the Workaround

    • This reply was modified 1 year, 5 months ago by  gingin0.

    I have the same problem under IE and MS Edge, even though I am not using any caching plugin. Plug-in Author please help us!!

    Same problem here. Accept-Button does not work. The box is not closing.

    Same problem here, web page is simply reloading every time accept is pressed and cookie bar appears again

    Two things I’ve seen so far:
    – If you enable “Share Cookie across Network”, and in the field for “Network Domain” you forget to take the www of your domain, putting http://www.domain.com instead of domain.com, the plugin will not work and will do exactly what happens to you.
    – If your site can be accessed by http://www.domain.com and http://www.domain.pt, the plugin will also only work for the domain that is placed in the backoffice for the site and the backoffice. Accessing the site with the other domain the plugin will not work and once again it will do what it does to you at the moment. If you open the error console you may see that it says “Cross-origin request. In Access-Control-Allow-Origin header”.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘Accept not working’ is closed to new replies.