Support » Plugin: WP eCommerce » Abysmal quality

  • I have wasted countless hours fixing bugs in this plugin. Just yesterday I was notified of an issue with a website with wpec 3.9. Hours later, I find the bug in wpec core code. Just to be sure, I downloaded the latest version, 3.9.5. It contains the same bug. I am *not* describing what the bug is–I refuse to do unpaid QA/code maintenance for I tried the Support > Jobs link in site, figuring they could use my services, and guess what? The page doesn’t exist.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You can submit issues and bug fixes here:

    You can see that the WPEC developers are participating and using github everyday. Since the WP e-Commerce Plugin is open source I’m sure that they would love your help and support.

    Using the right channels WPEC is your Plugin too 🙂

    Before then, you could submit issues to It so happens that in Aug. 2011, I submitted a request to modify code that was breaking a theme. Here’s the discussion (you may need to login to read it):

    I just checked the code in question–they still haven’t implemented my suggestion.

    Hi there.

    Sorry you had a bad experience using Google Code. Things have been improved… new team… new support systems… and new tools at Github. Please, I would encourage you to have a crack at submitting your issues / code in Github.

    The guys have overhauled the way they handle issues and requests and I’m sure things will get looked at in Github a lot more promptly.

    Since I was asked politely twice, I will oblige. But for the record, allow me to insert the code & the proposed fix here, since it consists of just one line, before following up at Github.

    wpsc-widgets/shopping_cart_widget.php line 83 is:
    <div class="wpsc_cart_loading"><p><?php _e( 'Loading...', 'wpsc' ); ?></p>

    it should be:
    <div class="wpsc_cart_loading"><p><?php _e( 'Loading...', 'wpsc' ); ?></p></div>

    This was causing the page footer to display in the middle of the page on a site I worked on. I traced it down after the page did not validate with the w3c validator.

    Plugin Author Justin Sainton


    Hi Yitwail,

    Thanks for following up here.

    I looked up your issue on GitHub –

    Looks like it was closed out a day after you reported it. The fix will be in our next release. Thanks for reporting!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Abysmal quality’ is closed to new replies.