Support » Plugin: Page Speed Optimization » abtf cache not working correctly

  • Resolved antforshaw

    (@antforshaw)


    Hi,

    I have noticed several 404 errors in the Chrome Developer Tools for my website, since using Above The Fold. I didn’t realise that Above The Fold cached fonts in the way that it is attempting to do here:

    https://www.newstaticsforsale.co.uk/wp-content/cache/abtf/proxy/cf/f2/fonts/fontawesome-webfont.woff?v=4.7.0

    But irrespective of that, the folder that it is trying to access the cached font from does not exist.

    My question(s) are:-
    1) How do I prevent that Fontawesome file from being cached? (or at least to be cached properly)
    2) Is this a known bug in Above the Fold? I’m reluctant to continue using the plugin if this is the case!

    Many thanks in advance,

    Anthony

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Optimalisatie.nl

    (@optimalisatie)

    Hi antforshaw,

    Thank you for your feedback! The described problem is not a bug.

    When using the proxy for stylesheets any relative paths within the CSS will be broken. The proxy does not modify CSS, it only serves the content from a local cache URL.

    To prevent font awesome from being proxied it is possible to enter a part of the URL (e.g. simply fontawesome) in the proxy exclude list.

    To resolve the leverage browser caching issue in Google PageSpeed Insights it may be an option to include the font awesome code in the critical CSS (we usually create a conditional critical CSS entry with the “append to any” option enabled specifically for fonts). As font awesome is very big, it would be best to specifically include the parts that are used on the website. You should then remove the font awesome CSS from the page. This could be done with the Remove List option on the CSS optimization settings.

    Please let us know if you manage to resolve the issue!

Viewing 1 replies (of 1 total)
  • The topic ‘abtf cache not working correctly’ is closed to new replies.