Support » Plugin: WP Security Audit Log » Absolute must have plug-in

  • Absolutely essential for running any multi-admin site. I’ve even used it to catch my own mistakes.

    Great Work!

  • The topic ‘Absolute must have plug-in’ is closed to new replies.