• Hi, I set up a category link assigned with permission to logged users. But a non-logged user can still access the URL. Why? But your original page, such as https://domain.com/account, it can not be accessed by a non-logged user. The URL will changed to log in URL and page will be changed to log in page. How do you realize it. It is the effect which I am looking for. Would you please tell me the secret? Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Aswin Giri

    (@aswingiri)

    Hello @kevinsmith4758

    You can set up content restrictions for the category and set it up to redirect to the login page like in this screenshot.

    If you don’t see content restriction setting on your category, you can enable it from wp-admin > ultimate member >settings > access > content restriction > Enable the “Content Restriction” settings for taxonomies

    • This reply was modified 1 week, 6 days ago by Aswin Giri.
    Thread Starter kevinsmith4758

    (@kevinsmith4758)

    Hi Mr. Giri, thank your for your support. However, I could not find the first screen shot of content restrictions. Would you please tell me where is the entrance. I can find the second screen shot but not the first one. Thank you very much.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @kevinsmith4758

    Did you check the taxonomy/category in the Access settings? Please go to wp-admin > ultimate member >settings > access > content restriction > Enable the “Content Restriction” settings for taxonomies. Once the taxonomy/category is checked, the content restriction settings will show that you see in the first screenshot.

    Thread Starter kevinsmith4758

    (@kevinsmith4758)

    Hi Mr. Giri, thank you for your reply. Maybe you plug-in is different with mine. I checked the category as you showed. But nothing happened. I still can not reach your first screenshot. What can I do?

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @kevinsmith4758

    Did you follow the steps above to enable the Content Restriction settings?

    What’s the version of Ultimate Member plugin you’re using on your site?

    Thread Starter kevinsmith4758

    (@kevinsmith4758)

    Hi, thank you for your reply.

    I used the Ultimate Members 2.3.2 version. I don’t know how to upload pictures. Or I will show you what I can see. Would you show me how to upload pictures?

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @kevinsmith4758

    You can upload the screen via http://www.imgur.com and then share the image URL here so we can review it.

    Thread Starter kevinsmith4758

    (@kevinsmith4758)

    Hi, Sorry for the late reply. When I checked the category of the UM, it never showed the first screetshot. what I can see is in the following. I just find it was in other languages. I will upload again.

    Thread Starter kevinsmith4758

    (@kevinsmith4758)

    I upload again as following content restriction

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.