Support » Theme: OceanWP » about fonts

  • Hi!

    I am using Open Sans condensed in all my headlines (and I like it that way).
    When I tried to remove google fonts in my settings the headlines all changed to something else and did not look as good.

    So my question is this means that google fonts are necessary if I want Open sans condensed in my headlines? Or if there is another solution?

    Best regards
    Ann

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hello,

    To use google fonts, you need to use the google font settings.
    And google font condensed is the font of google.
    https://fonts.google.com/specimen/Open+Sans+Condensed

    if you disable the google font settings, then how will you use the google font (open sans condensed).

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Thank you, I am not an expert in fonts so I had no idea it was included in the google font library only.

    May I ask if there is another font, within the oceanwp theme, that is a bit similar and that I can use instead? So that I can get rid of google fonts 🙂

    Best regards
    Ann

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Hi again,

    So I decided to go with ARIAL as my font for headers. But it just will not change to that after I have disabled Google fonts? It is so strange. As soon as I disable google fonts my headings go to some other kind of font? Why is that?

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Hi did you see this?

    Hello,

    That is because you are using google font for your heading. If you disabled the google font, then how it will apply to the elements that are using google font?
    In that case site use the fallback fonts.

    Thread Starter ayoungerskin

    (@ayoungerskin)

    I did not know I was using google font in my header. How do I remove it from there? In elementor? Are the options to remove them from elementor?

    If you want to disable it from elementor, following the post may help you.
    https://elementor.com/help/speed-up-a-slow-site/

    and If you want to disable from the theme, please check the doc.
    https://docs.oceanwp.org/article/253-remove-all-google-fonts-from-the-typography-settings-panel

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Thank you, so these are the only options? Just disabling google font in customizer will not be enough?

    I do not have a child theme. Can I add these codes without it?

    Best regards
    Ann

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Also another question. I noticed that my headlines on mobiles are in ARIAL now, as I had them set in customizer. But they are very very large. IS there a way to make the headlines a bit smaller?

    Hello,

    Disabling it only from the customizer will load in the backend, you need to add the code.

    If you don’t have the child theme, either you can install it by following the doc or you can also use a plugin like woody to add the code.
    https://docs.oceanwp.org/article/90-sample-child-theme
    https://wordpress.org/plugins/insert-php/

    And If the heading is large for the mobile, please change the font size for the mobile from the customizer.

    Thread Starter ayoungerskin

    (@ayoungerskin)

    Ok I will look into that plugin.

    ABout making my headlines smaller on mobiles. I am not sure what to choose once I am in the customizer – typography – H1. I find my way to change the size in mobiles but what should I add in the box? A number, a percentage? I do not understand? Also I tried different numbers but nothing happened when I pressed publish.

    Best regards
    Ann

    Hello,

    you can select any number or percentage, these are only units.
    And It depends on that which one suits the site.

    Kindly share snapshots of the setting which you are trying and not working.

    Thread Starter ayoungerskin

    (@ayoungerskin)

    I figured out that if the headline does not use only uppercase letters, then it will look ok. But hen, next question, how do I change the H1 and page title to not be only in capitals? If you look now on my website (please see the site to understand) I have the titles good on the home page. But then if you click on one of the blog posts the titles are only in capitals. And therefore looks huge.

    In customizer they are all set to default at the moment.

    Best regards
    Ann

    Hello,

    Go to Appearance > CUstomize > Blog > Blog ENtries, from here select the heading tag as h1.
    Now, go to Appearance > Customize > Typography > Blog Entry Title, from here set the Text Transform according to need.

    Thread Starter ayoungerskin

    (@ayoungerskin)

    No, I think you misunderstood. My blog post titles look good on my homepage, and I suppose that is what is called Blog entries? 🙂

    The problem is when you go to a single blog post. THen the title is in only capitals. I want these titles to only have one capital at the beginning of the title.

    Best regards
    Ann

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.