WordPress.org

Forums

[resolved] Abort class-pclzip.php error when installing plugins (6 posts)

  1. repomonkey
    Member
    Posted 6 years ago #

    Hey all - wonder if someone can point me in the right direction. We were having all sorts of problems with WP2.8 and so we upgraded PHP on our Apache server to 5.2.6. Everything is working perfectly apart from one annoying bug. Whenever we try to install or upgrade a plugin we get an error, "Abort class-pclzip.php" and it craps out. This is clearly a missing zip function that somehow got lost in the upgrade, since we can FTP plugins up with no issues at all. So could someone please tell me how to fix it? I have full root access to our co-hosted server.

  2. repomonkey
    Member
    Posted 6 years ago #

    Okay. Got to the bottom of this myself. Zlib wasn't enabled in the php.ini file on the server. Added the appropriate extension command and everything's fine again now.

  3. TooNA1
    Member
    Posted 6 years ago #

    What line of the php.ini do you enable?

  4. TooNA1
    Member
    Posted 6 years ago #

    I am on an apache VPS server and I get the same error message:
    Abort class-pclzip.php : Missing zlib extensions

  5. TooNA1
    Member
    Posted 6 years ago #

    I reinstalled all of my extensions using the utility my webhost for php.
    Problem solved. <-------- noob

  6. swedish boy
    Member
    Posted 6 years ago #

    I ran WordPress on my own VPS and got this error.
    It might be caused by a bug in php's zlib package.

    This guide helped me update php.
    http://www.linode.com/forums/viewtopic.php?t=4836

Topic Closed

This topic has been closed to new replies.

About this Topic