Support » Installing WordPress » able to login back-end, but BLANK at front end url

  • I just transferred a blog to a new URL. basically replacing old HTML site with WP site.

    – FTP’d content and files
    – imported mySQL db uploaded properly…
    – i login to /wp-admin.php and everything is there, pages, media files, posts, etc.
    wp-config.php seems to be correct…
    however, nothing loads at main URL
    (if inappropriate to post up URL – admins, please let me know)

    does anyone have any ideas of what I might be missing?


Viewing 15 replies - 1 through 15 (of 22 total)
  • just a clarification:

    I have deleted index.html so there is only


    also tried adding .htaccess as below, but nothing…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    looking at the source code for the main url it shows

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>

    so, i’m assuming for some reason it is not calling the php files, but everything is there in the backend… really weird…

    I just re-uploaded all WP related files to the new server, changed the wp-config.php file appropriately, but still no luck. Still looking at a blank page…



    Looks like a PHP syntax error in your theme or your theme’s functions.php , or even in one of your plugins. Try using the default theme. If that works. There is an error in one of your theme files. If that didn’t work. It could be an error in your plugins. You can check that by de/activating them.

    Good luck!

    Read this one:

    Maybe a messed up index.php in the root.

    Hi guys, thanks for the comments.

    Since I’m able to get to backend admin, I tried the following:
    1. changed the theme to default WP theme (kubrick)
    2. deactivated all plugins
    3. republished all posts and pages

    Also, checked wp-config.php to make sure there were no “extra” lines at the end of the file (as I’ve found that seems to be common error).

    henkholland, i checked my index.php and it looks ok:

     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     * @package WordPress
     * Tells WordPress to load the WordPress theme and output it.
     * @var bool
    define('WP_USE_THEMES', true);
    /** Loads the WordPress Environment and Template */

    another thought… not sure if this could be an issue…

    when I prepped the mySQL DB for upload to the new server, I changed all references from the old URL to instead of just

    i also have the URL in the settings panel pointing to

    I think that should be OK as I’ve done it before…

    one more thought…

    the site was designed in WP 2.8.5

    the new server has 2.5.6


    And that index.php is in the root, right, next to wp-contig.php etc?

    the root has the three folders

    and then the files
    etc. etc…

    My server support sent this information:

    I do note that the cgi_error_log [which can be found in the ‘stats’ folder of your account] has a lot of errors at the end:

    PHP Fatal error: Call to undefined function is_admin() in /hermes/web03/b512/moo.imack03/day/wp-includes/vars.php on line 16

    I have heard of other customers having an issue with WP 2.9, and the error message does support there being a problem of some sort with the code. Reverting back to the previous version would seem the best bet at this point.

    you can see my cgi error log? wow! I’m not sure if that is good or bad?

    I’m not on 2.9 now… just developed the site in 2.8.5, but installed 2.8.6 on the new server that I transferred everything to… I’ll check into how to revert back to 2.8.5 on the new server.

    Is there anything else that I can do to fix the PHP Fatal error in vars.php?

    Imack is referring to his own problem!! It says Imack in this line: hermes/web03/b512/moo.imack03/day/wp-includes/vars.php

    There’s nothing really between 2.8.5 and 2.8.6 so I would not bother.

    Two questions left for me:
    1. Since you have sql/server access, are there any error logs there?
    2. This would not be a host that does not like stuf in the root (or is the “root”stil within “http” or “public_html” or something like that?

    Note: I saw that you did put the html site back on. No problem: url + index.php still goes to your problem.

    hi henk,

    1. no error logs that I can see
    2. on the FTP structure, there is actually nothing in the root folder except a folder “artcretedesigns” that everything is in… cgi-bin, index.html etc…

    I wonder if I need to rewrite the htaccess to

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /artcretedesigns/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /artcretedesigns/index.php [L]
    # END WordPress

    I just tried that, and nothing… so maybe something similar??

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘able to login back-end, but BLANK at front end url’ is closed to new replies.