WordPress.org

Forums

ABASE
ABASE doesn´t display german umlauts (äöüß) (5 posts)

  1. MaxxWaxx
    Member
    Posted 1 year ago #

    ABASE doesn´t display german umlauts (äöüß)

    What can i do?

    https://wordpress.org/plugins/abase/

  2. willswing77
    Member
    Posted 1 year ago #

    I had the same problem here. Strangely, when I put my tables in the same DB as WordPress, the problem disappears.

    On another instance of my installation changing everything to the newest releases (MySQL -> MariaDB, PHP, WordPress itself) solved the problem too. In this setup I did not put the tables into the WordPresss instance and left it in its own database. MariaDB seems to work differently.
    Why all this happened: I do not know...

  3. MaxxWaxx
    Member
    Posted 1 year ago #

    Perhaps i found the solution that might work:
    Wordpress -> Plugin -> Edit -> Put this after the database-connection:
    $con->set_charset("utf8");

    Könnte funktionieren :-)

  4. GMRobbins
    Member
    Posted 9 months ago #

    Date format has me perplexed.

    [abase table="events" columns="event_name,city,state,start_date" where="AND start_date = 'today'" ORDER="start_date DESC" LIMIT=15]

    What I would like to show is the next 15 events after "today"! Any asistance would be appreciated!

    Love this plugin and hope to see it developed further! :( sorry this was posted inside another thread :(

  5. SwedishElk
    Member
    Posted 5 months ago #

    For those with UTF8 problems.

    Find and Edit: abase/abase.php

    Find this part of the code:

    $abase_conn = mysql_connect($sqlHost, $sqlUser, $sqlPass) or die("<BR><font style='color: $error_color; background-color: white;'>".$GLOBALS['bus311mtd_page_shortcodes']."<B>Fatal Error</B> (".__LINE__.") - Couldn't connect to MySQL server on '$sqlHost'.<BR><BR>This shortcode uses Database #$db_in. If this is correct, then see the <B>Warning</B> above. One or more of the following settings for Database #$db_in is probably not correct.<OL style='background-color: white;'><LI> Database host: '$sqlHost'.<LI> Database user: '$sqlUser'.<LI> Database user password: '$sqlPass'.</OL></font>.");

    And add:

    // We want UTF8.
    mysql_set_charset("UTF8", $abase_conn);

    Before this part:

    $db = mysql_select_db($sqlDatabase, $abase_conn) or die("<font style='color: $error_color; background-color: white;'>".$GLOBALS['bus311mtd_page_shortcodes']."<B>Fatal Error</B> (".__LINE__.") - Couldn't select database '$sqlDatabase'.<BR>" . mysql_error() . "<BR><font style='color: $error_color; background-color: white;'><BR>This shortcode uses Database #$db_in. If this is correct, then one or more of the following settings for Database #$db_in is probably not correct.<OL style='background-color: white;'><LI> Database name: '$sqlDatabase'.<LI> Database '$sqlDatabase' must be accessible by user '$sqlUser'.</OL></font>");

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • ABASE
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic