WordPress.org

Support

Support » Plugins and Hacks » WP-United : phpBB WordPress Integration » Abandoned plugin? Alternatives

Abandoned plugin? Alternatives

  • Has this plugin been abandoned? They seem to think so on the phpBB forums.

    It would be a real shame because I suspect there are plenty of people out there who really want to sync their WordPress blogs with a phpBB board.

    Are there alternatives to bridge the two platforms? Or will WP United return? At the moment it’s impossible to install even the abandoned plugin because the WP United site is down.

    http://wordpress.org/plugins/wp-united/

Viewing 15 replies - 1 through 15 (of 23 total)
  • I think you are right. After putting some effort into this I started looking around. The author has not meed active on either this site or phpbb forums since early March.

    I think there is little hope that this will be resolved or updated.

    That stinks.

    I really like phpBB but need at least a good cross user integration where users must sign up through WordPress.

    Does anyone have any suggestions or ideas? There are a few out there that look like they might work. I am just a little frustrated by getting this all setup just to realize this has been abandoned and is not supported.

    I have it working with phpbb 3.52 without a problem. I am going to do some testing later next week with version 3.6, but so far it requires very little modification to make it work.

    I can confirm what jeremiah411 already stated. I have it running beautifully on 3.52. I am looking into 3.6 as well and don’t think there will be a problem upgrading to it as I don’t see anything in the update that would have changed how the plugin interacts with wordpress. I will also report back after I upgrade.

    ok, thanks for the insight. Does anybody have the phpBB modification package – the WP United website is still down do I can’t download it.

    For alternatives wp bridge works very well for the user role mapping/seamless login. It does not do the cross posting though, which is a real shame. I have been able to find any alternatives for the cross posting.

    I deleted the php portion’s zip once I installed it. Sorry.

    I take that back. I do have it still, I uploaded it to my webserver. If you would be kind enough in return, throw a comment up on my site as I have been trying to test comments. Thanks. Download it here.

    Thanks

    Okay as far as I can tell, it seems to be working fine with 3.6. I will look closer when I am able.

    Azhure

    @nymphetaminerx

    I noticed the area where you set up the automated user integration is a bit broken. The red squares and blue circles are out of place, like something is being called at the wrong time in the PHP or CSS. (I don’t actually know, I’m not very good at either of those things.) Is anyone else experiencing that problem as well?

    Right now, the integration from WP to phpBB appear to be working with 3.6 and the current phpBB.

    Thanks Elite-Wright for uploading the integration package, you are a life saver. <3

    I couldn’t get it to work. The integration package failed at includes/functions_user.php where it has to replace

    function validate_username($username, $allowed_username = false)

    Apparently that line doesn’t exist in my functions_user.php file.

    It is supposed to be replaced with:

    if(!function_exists('validate_username') && (!defined('WPU_BLOG_PAGE')))
    {
    	function validate_username($username, $allowed_username = false)
    	{
    		return phpbb_validate_username($username, $allowed_username);
    	}
    }
    function phpbb_validate_username($username, $allowed_username = false)

    I’m currently running php bridge as well. Could that be the problem?

    Thanks for the download Elite-Wrigt!

    When I upload, I keep getting the following error:

    Information

    Unexpected header, ending loop

    No idea what to do next.

    I’m currently running php bridge as well. Could that be the problem?

    It certainly sounds like that is the problem. Your using two plugins that are attempting to do the same thing.

    I noticed the area where you set up the automated user integration is a bit broken. The red squares and blue circles are out of place, like something is being called at the wrong time in the PHP or CSS. (I don’t actually know, I’m not very good at either of those things.) Is anyone else experiencing that problem as well?

    Upon you mentioning it, I notice this as well on my installation. As I already had integration configured everything still seems to be functioning properly, just not displaying. I haven’t tried this but the read me file suggests deleting the cache file in the wp-contents/plugins/wp_united/cache/ when upgrading versions of the plugin or wordpress.

    For someone trying to set it up I might suggest backing up all your stuff, downloading and installing WordPress 3.5.2 and setting up your wp_united plugin there and then once your happy with it upgrade to 3.6.

    When I upload, I keep getting the following error:

    Can you be a little more specific as to what you have done and what your still trying to do. Have you successfully run the WordPress wp_united installer? Also, are you using a style other than prosilver or subsilver (the phpbb3 plugin has additional instructions included if your using subsilver theme) on your PHPBB3? If you are you need to make any theme related changes to the theme you are using.

    I simply forgot to manually upload the .zip AutoMOD delivers after install of the phpBB3 mod.

    Everything went smoothly after that.

    Azhure

    @nymphetaminerx

    I don’t know if it was clearing the cache or if it was a clever use of the broken CSS, but I got the user integration working.

    If you drag the right hand blue circles just away for a moment, despite its location, it will create blue circles in the left hand group. You just keep dragging the same blue one, to make all the blue circles for the phpBB groups. Then you do the same with the red one. And then you can process the user integration despite the broke CSS/PHP.

    Someone more savvy might be able to easily fix this if they chose to take over the mod’s development.

    But thanks again, Elite-Wright, because it’s working in 3.6 for me now, and I have all my users mapped without needing to downgrading back to 3.5.2.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Abandoned plugin? Alternatives’ is closed to new replies.
Skip to toolbar