WordPress.org

Support

Support » Plugins and Hacks » UpdraftPlus WordPress Backup Plugin » [Resolved] a zip error occurred

[Resolved] a zip error occurred

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author David Anderson

    @davidanderson

    Click on the ‘Download most recently modified log file’ link; then search in there for any likely zip errors to see what it says.

    David

    Here’s what it says. What does it mean? It ways this back up set was empty. Doesn’t refer to the zip errors?

    0000.000 (0) Opened log file at time: Fri, 30 Aug 2013 18:16:52 +0000
    0000.008 (0) UpdraftPlus: 1.7.1 WP: 3.6 PHP: 5.3.26 (Linux hp111.hostpapa.com 2.6.32-458.6.2.lve1.2.28.el6.x86_64 #1 SMP Wed Jul 3 13:39:48 EEST 2013 x86_64) MySQL: 5.5.32-cll Server: Apache safe_mode: 0 max_execution_time: 900 memory_limit: 128M ZipArchive::addFile : Y
    0000.011 (0) Free space on disk containing Updraft’s temporary directory: 172266.6 Mb
    0000.019 (0) Tasks: Backup files: (schedule: weekly) Backup DB: 1 (schedule: weekly)
    0000.020 (0) Processed schedules. Tasks now: Backup files: Backup DB:
    0000.022 (0) An email has been scheduled for this job, because we are in debug mode
    0000.022 (0) No email will be sent – this backup set was empty.
    0000.023 (0) The backup apparently succeeded (with warnings) and is now complete

    Plugin Author David Anderson

    @davidanderson

    Hi,

    That’s a different log file from the one that has the original message in. Click on the big “Restore” button and try to locate the log file that corresponds to the backup that was running when you got the message.

    David

    Having the same issue. I checked the log file and it’s probably too big to post here (1897 lines long) but did see the following ZIP errors:

    0075.574 (0) Binary zip: error (code: 15)
    0075.579 (0) The attempt to close the zip file returned an error (). List of files we were trying to add follows (check their permissions).

    Toward the end it says:

    3081.669 (2) There were no errors in the uploads, so the ‘resume’ event (3) is being unscheduled

    and the last line is:

    3082.115 (2) The backup apparently succeeded (with warnings) and is now complete

    Does this mean the backups are not working as expected? Just need to make sure I can restore from this backup in the event of a failure. Let me know if you’d like me to email the whole log file.

    Thanks!

    Plugin Author David Anderson

    @davidanderson

    Yes, the whole log file, please.

    Post here or email?

    If email, let me know the address you want it sent to.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    If you do post here please consider using pastebin.com and following these instructions from the forum welcome.

    http://codex.wordpress.org/Forum_Welcome#Posting_Code

    Plugin Author David Anderson

    @davidanderson

    Use pastebin, please.

    Will do.

    David, is there typically anything contained in the complete log file that should make me skeptical about posting the whole thing here? There appears to be some hosting info that makes me a little worried…or should I relax and Pastebin it?

    I am having the same error on multiple sites.

    http://pastebin.com/6v4WiEv0

    Plugin Author David Anderson

    @davidanderson

    Hi,

    Yes, it’ll contain some info about the hosting setup. It’d be ‘interesting’ to a hacker (background info), but not directly useful. Also, if you’re with a public web hosting company, they could get the info through other means cheaply/easily.

    If you prefer to not do it through a public forum, then there’s commercial support: http://updraftplus.com/shop/

    Best wishes,
    David

    David,

    I obscured some of the hosting info…hope that doesn’t interfere with your ability to diagnose.

    http://pastebin.com/FCVKkPRf

    Let me know if this expires before you get to it.

    Thanks again!

    Plugin Author David Anderson

    @davidanderson

    Overdogart: When I click that link, it says: “This paste has been removed!”

    philmcdonnell: I think your hosting company has something that kills off zip processes after 15 seconds. Stick this in your wp-config.php to enforce use of a different zip method to prevent the problem:

    define('UPDRAFTPLUS_NO_BINZIP', true);

    David

    Thanks I will give it a shot! There is a nobody check and it thinks the zip is a malicious process…

    I added that line to the end of the the config file, logged in, ran another backup and got the same error. Here’s the log file:

    http://pastebin.com/SA9D3d7S

    Any ideas?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] a zip error occurred’ is closed to new replies.
Skip to toolbar