Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » A Warning – "ngg_delete_expired_transients" Cronjob

  • Sorry to say, I´m angry and that´s not funny anymore and now i´m a little bit fed up.

    The latest update (2.0.23) is flooding my cronjobs, and i have to delete all of them piece by piece by hand. The updated Plugin writing nearly every 1 second a new cronjob, guess what the server did – it died. Imagine nearly 3 hours passed since the update and the surprising discovery, and that´s last but not least not the only domain I have to administrate.

    Only solution, up to now, revert to prior version. And to all the others, look into the logs to verifiy it´s not happening to you. For the unlucky out there the plugin “what´s in cron” will show you all active crons and the plugin “crontrol” will help to delete them.

    Have a good day!

Viewing 15 replies - 1 through 15 (of 34 total)
  • I am just commented in nextgen-gallery/nggallery.php this code:

    // Delete displayed gallery transients periodically
    		// add_action('ngg_delete_expired_transients', array(&$this, 'delete_expired_transients'));
    		// if (!wp_next_scheduled('ngg_delete_transients')) {
    		//	wp_schedule_event(time(), 'hourly', 'ngg_delete_expired_transients');
    		// }

    Thanks for the quick solution.
    I just discoverd this workaround by myself a few minutes away. Nevertheless you saved my day.


    Hmmmm! It is very simple! In code have bug! :))) For correct fix it needed just change a code (changes in bold):
    // Delete displayed gallery transients periodically
    add_action(‘ngg_delete_expired_transients’, array(&$this, ‘delete_expired_transients’));
    if (!wp_next_scheduled(‘ngg_delete_expired_transients’)) {
    wp_schedule_event(time(), ‘hourly’, ‘ngg_delete_expired_transients’);

    After this created only one cron job.

    You are not alone. Last night my website went down but thanks to the dedication of my hostgator geeks, I found out that this issue has already been addressed and a fix should be available soon. Not a happy camper either.

    Thank you, aselektor! It worked just fine. I disabled the plugin before changing it. Not sure if it matters, but just to be on the safe side. Galleries are now working just fine. Hopefully this bug is fixed on their next update.

    Vera Schafer, thank you!


    This provcess has totally blocked one of the sites i run. For one entire night and half a day!!

    I will definitely quit NGG, a very bad plugin. It used to work before photocrati took over ..

    Like 1Aus above I AM FED UP

    I used the plugin FFF Cron Manager for cleaning WP cron

    Thanks, aselektor, for the crucial notes. However, even when I delete those cronjob-lines with fff cron manager, they keep coming back… 🙁

    Mkalina, you need deactivate NGG, before delete all bad cron jobs.
    Change nggallary.php (see above) If you want run NGG again.

    aselektor, I could solve the problem myself:

    1. Deactivate NGG.
    2. Change the hook’s name as aselektor put it.
    3. Reactivate NGG.

    What I did – in addition:

    1. I added this line to functions.php. It deletes all photocrati mess rather quickly: wp_clear_scheduled_hook( 'ngg_delete_transients' );
    2. I checked with fff cron manager and all NGG lines were gone.
    3. I reactivated NGG and now I start looking for an alternative. Enough is enough.

    where did you add the line
    wp_clear_scheduled_hook( ‘ngg_delete_transients’ );
    in your

    When I add this line at the end, it gives me an error.

    No, gandalfhh, you have to put it in your theme’s functions.php (and remove the line, once fff cron manager does no longer show the cronjobs.)

    that worked perfectly. thx.

    Plugin Author photocrati


    All – We do apologize for all of this. We are working as fast as possible to develop a patch and get it released as soon as we can.

    Please bear with us while we are preparing this release to address these specific issues with CRON and transients.

    We cannot imagine the frustration this is causing and can only beg for your patience as we work to get this resolved.

    – Cais.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘A Warning – "ngg_delete_expired_transients" Cronjob’ is closed to new replies.