Support » Fixing WordPress » A very long post about includes and a wp-settings.php error = HELP!

  • Sorry to post this again but someone hijacked my last post so I closed it.

    Here are the variables…

    I am using WordPress 2.6

    I have successfully installed FluxBB 1.2 and 1.3 locally and live on site a and site b. I tried to include each sites WordPress header using these include methods…

    1. Their recommended format…

    ‘<?php require(PUN_ROOT.”../wp-blog-header.php”);?>
    <?php get_header(); ?>’

    2. The format that I use with my gallery software…

    ‘<?php require_once(“../wp-blog-header.php”);?>
    <?php get_header(); ?>’

    3. A variation…

    ‘<?php require (“../wp-blog-header.php”);?>
    <?php get_header(); ?>’

    In all of these cases the header is called up perfectly except when I try to log in or bush any button on the FluxBB end.

    I get this message…

    ‘Fatal error: Call to a member function set_prefix() on a non-object in /xxxx/xxxx/xxxxx/phauxshow/wp-settings.php on line 212’

    wp-settings.php line 212 says…

    ‘line 212 says $prefix = $wpdb->set_prefix($table_prefix);’

    I have posted the same question in the FluxBB forum and have scoured both the internet and this forum for an answer. If there is one it is either buried deeply or right under my nose!

    I really hope someone can point me in the right direction here as I really don’t want to give up. Isn’t giving up after working for days on something kind of crappy?

    Oh, and just so I don’t get accused again of not searching before posting, I have pretty much ruled out these methods as relevant or helpful… … on-plugin/

    Also, in all cases I have confirmed that I have installed the complete WordPress package.


Viewing 10 replies - 1 through 10 (of 10 total)
  • Just wanted to give the daytime folk a crack at this…

    Still working at it. I tried it on a WordPress 2.5 installation that I had running locally and it worked. That doesn’t help me though as all of my live sites are running 2.6

    I’m just trying to narrow down what the problem night be – but I must admit I taking random shots in the dark here!

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    … Could you give us an example URL that shows this issue?

    And explain what “FluxBB” is?

    Sure, FluxBB is a fork of PunBB. It’s forum software. Their site is here.

    I’ve been trying to get this to work to the point that I even tried it live just to test if the problem might be with my local setup.

    There’s no link to it from my home page but my live installation is here.

    Feel free to click around. If you try a simple operation such as a search you’ll see the error message I mentioned.

    Otto42, I feel better knowing your on it!

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Hmm.. Without looking at how exactly you attempted to integrate WordPress, I’m not sure what to tell you. Somehow, your require call is not fully happening or some such thing.


    Thanks for looking! I’ve tried every way I can think of to integrate and get the same error message for each.

    The particular method for integration I am using at the moment as per the FluxBB instructions calls up this include…

    ‘<?php require_once(PUN_ROOT.”../wp-blog-header.php”);?>
    <?php get_header(); ?>’

    I’ve tried all of the other variations I mentioned above. FluxBB has their own include method which involves adding an include tag (<pun_include “header.php”>) to a template file and then placing the code above in a set directory (forums/include/user/header.php).

    In the end it seems to not matter whether I use their include system or just add the standard WordPress includes – I get the same error.

    I’m sorry to be so persistent about this. I’m just at the point now where I’m going to have to admit failure!

    Is there any reason why it would work with WordPress 2.5 and not 2.6?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Yeah, but WHERE does it do that include? I mean, that really tells me nothing. I don’t know their software. I don’t know how it integrates.

    Simply calling <?php require_once 'wp-blog-header.php';?> will not give that error. So something else is going on there.

    Thanks for taking the time to have a look, Otto42! Sincerely, I feel a lot better knowing it’s not some simple problem I’m overlooking.

    I’m going to work on it over the weekend and then move on. I’ll resolve this thread if I find anything.


    Not resolved.

    I ended up recreating the WordPress header in the Fluxbb forum. It worked but I still have to clean up some code for the nav bar when using IE6.

    You can have a look at it here – although, I’m going to be uploading an update this week.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘A very long post about includes and a wp-settings.php error = HELP!’ is closed to new replies.