Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » A variable mismatch has been detected.

  • Resolved veebid

    (@veebid)


    Hello,

    When I try to change image caption then I get this error:

    “A variable mismatch has been detected.”

    I tryid to deactivate all plugins but nofthing changes.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Thread Starter veebid

    (@veebid)

    Info:
    Wordpress ver 5.0.1
    PHP ver 7.2
    NextGen Gallery ver 3.1.1

    Same here after security update 4.9.9 – yesterday it works – today after update – not.

    If I want to jump to a special page in galleries list – > A variable mismatch has been detected.

    If I want to detect new images in a gallery (uploaded with FTP) -> A variable mismatch has been detected

    • This reply was modified 2 years, 2 months ago by ODAK71.

    Looks like WP as of 5.0.1 now checks if $_GET[‘somevar’] != $_POST[‘somevar’]. If the values aren’t the same for “somevar” across $_GET and $_POST this error is now thrown.

    https://core.trac.wordpress.org/browser/trunk/src/wp-includes/class-wp.php#L299

    Plugin Author Imagely

    (@imagely)

    Hi @veebid!

    Could you please share with us how to reproduce the same issue?
    Please, complete this form: https://www.imagely.com/report-bug/

    Let the support team know that Gaby sends you.

    – Gaby

    Hello Gaby,

    If i try to check an image gallery folder for new via FTP added Images, there is an button.

    Here is the get action:

    admin.php?page=nggallery-manage-gallery&mode=edit&gid=232&paged=1

    Here is the post parameter:

    /wp-admin/admin.php?page=nggallery-manage-gallery&mode=edit&gid=232&_wpnonce=8b7a3e612a

    As cartpauj wrote:

    WP as of 5.0.1 now checks if
    $_GET[‘somevar’] != $_POST[‘somevar’]

    the get and the post list of variables are different.

    I suppose that’s the problem.

    Hi,
    I have the same problem here whenever I want to update captions of pictures in my galleries. My website runs WordPress 4.9.9, Nextgen 3.1.1 and PHP 7.0.32.
    Everything worked well before the update to WP 4.9.9 though.

    Hi,

    is there a possible fix or workaround for this problem? I get the same error, when i try to save changes in a gallery.

    I already tried all possible fixes, like updating the plugin or wordpress, deactivate other plugins, clear caches etc.

    Link to a picture with the displayed error: https://imgur.com/a/lWFf8St

    Greetings, bweing

    Hi,

    I am having the same issue when resetting the password.

    I also have this problem “A variable mismatch has been detected”
    WP 5.0.1
    Gallery 3.1.1

    Hi! I also have this problem “A variable mismatch has been detected”
    WP 5.0.1
    Gallery 3.1.1

    Need help!

    I also have the same problem:

    When I try to change image caption then I get this error: “A variable mismatch has been detected.”

    Using:
    WordPress 5.0.1
    NextGEN Gallery 3.1.1
    WPML Media 2.4.1
    WPML Multilingual CMS 4.1.2
    WPML String Translation 2.9.1
    WPML Translation Management 2.7.1

    See NextGen Gallery and WPML give “A variable mismatch has been detected.” error mes

    Plugin Support edanzer

    (@edanzer)

    Hey all – Erick, CEO at Imagely. There are enough reports on this issue that we consider it high priority. It probably needs an immediate release.

    However, we are unable to duplicate it.

    Gaby noted above that we’d like to have someone with this issue submit a bug report. Once we get the bug report, we can get creds for a site with the issue and troubleshoot it.

    Time is of the essence given the holidays coming up this weekend. So if anyone here has this issue and is willing to have us login into and look at your site, I want to encourage you to please submit a bug report as soon as possible:

    https://www.imagely.com/report-bug/

    Put “For Erick” or “For Gaby” in the subject so it gets our attention.

    • This reply was modified 2 years, 2 months ago by edanzer.
    Plugin Support mweichert

    (@mweichert)

    Hi there!

    I’m trying to reproduce this one but not with much luck. Do you mind posting which theme you’re using please, as well as what hosting company you’re with.

    Thanks!
    Mike

    Plugin Support mweichert

    (@mweichert)

    @veebid, @odak71, @dsnpevl, @gray321, @jomol, @onebit, @bweing, @odak71, @ppahv, @cartpauj

    Would any of you mind trying the following patch to see if it resolves the issue please?

    Download 3.1.1.5

    Thanks,
    Mike

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘A variable mismatch has been detected.’ is closed to new replies.