Support » Plugin: Events Manager » “A variable mismatch has been detected.”

  • Events Manager Version: 5.9.5
    WordPress Version 5.0.3

    A user on my website is repeatedly getting the error message “A variable mismatch has been detected.” when trying to add an event.

    They previously added events without a problem and I am not able to recreate the problem.

    I have also looked in out server’s error logs and found nothing.

    Is there anything that could be causing this problem?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 55 total)
  • This error has happened again now… I haven’t changed anything… Please let me know when fixed.. my customers are losing patience over this being so unreliable…

    It seems when an image is added to the event, then the error appears. If no image added, the event is okay. I have tried with a png and with a jpg… HELP PLEASE!

    anyone there??

    Plugin Support angelo_nwl

    (@angelo_nwl)

    does it make any difference using the latest EM dev version 5.9.5.2 ? for dev versions, go to events > settings > general > admin tools

    I have the same problem and my customers are also confused.

    The version 5.9.5.2 unfortunately did not solve the problem.

    I changed the PHP Version from 7.2 to 7.1. The problem still existed.

    Then I tried version 5.9.5.2 of the plugin which did not solve the problem.

    Then I downgraded wordpress to 5.0. That’s for sure not the best way, but SOLVED the problem so far, so that my cuostomers can keep on working.

    I am now waiting for a release of the plugin that runs with the newest wordpress version.

    Thank you!

    Mickael Maury

    (@mickaelmaury)

    Same problem with a WordPress 5.1.x website and PHP 7.1.

    Plugin Support timrv

    (@timrv)

    Hello,

    I’m using WP 5.1.1 and Latest EM with PHP 7.1. SO far I don’t see any problem with “A variable mismatch has been detected.” Could you perhaps try and Update to the latest dev version? Events > Settings > Admin Tools

    Is there perhaps any specific steps that I should do or page to go to see the error? A screenshot would help also.

    Mickael Maury

    (@mickaelmaury)

    @timrv I am sending you the debug information below.

    ### WordPress ###

    Version: 5.1.1
    Language: fr_FR
    Permalink structure: /%year%/%monthnum%/%day%/%postname%/
    Is this site using HTTPS?: Yes
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 30
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.

    ### Installation size ###

    Uploads Directory: 17.98 MB
    Themes Directory: 45.42 MB
    Plugins Directory: 216.87 MB
    Database size: 9.28 MB
    Whole WordPress Directory: 591.94 MB
    Total installation size: 601.22 MB

    ### Drop-ins ###

    advanced-cache.php: Advanced caching plugin.

    ### Active Theme ###

    Name: Aardvark Child
    Version: 1.0
    Author: GhostPool
    Author website: http://www.ghostpool.com
    Parent theme: Aardvark
    Supported theme features: post-thumbnails, custom-background, wp-block-styles, align-wide, editor-styles, editor-style, automatic-feed-links, post-formats, title-tag, customize-selective-refresh-widgets, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, sensei, buddypress-use-legacy, menus, widgets

    ### Other themes (1) ###

    Aardvark (aardvark): Version 3.4 by GhostPool

    ### Must Use Plugins (1) ###

    ManageWP – Worker Loader: By ManageWP

    ### Active Plugins (34) ###

    Aardvark Plugin: Version 2.2.2 by GhostPool
    Akismet Anti-Spam: Version 4.1.1 by Automattic
    BackWPup: Version 3.6.8 by Inpsyde GmbH
    bbPress: Version 2.5.14 by The bbPress Community
    BP Profile Search: Version 4.9.8 by Andrea Tarantini
    Broken Link Checker: Version 1.11.5 by Janis Elsts, Vladimir Prelovac
    BuddyPress: Version 4.2.0 by The BuddyPress Community
    BuddyPress Xprofile Custom Fields Type: Version 2.6.4 by donmik
    Contact Form 7: Version 5.1.1 by Takayuki Miyoshi
    Cookie Notice: Version 1.2.46 by dFactory
    Duplicator Pro: Version 3.8.1.3 by Snap Creek
    Easy Updates Manager: Version 8.0.3 by Easy Updates Manager Team
    Envato Market: Version 2.0.1 by Envato
    Events Manager: Version 5.9.5.2 by Marcus Sykes
    Give – Donation Plugin: Version 2.4.3 by GiveWP
    Google Analytics Dashboard for WP (GADWP): Version 5.3.7 by ExactMetrics
    Gravity Forms: Version 2.4.6 by rocketgenius
    Gravity Forms User Registration Add-On: Version 4.0.4 by rocketgenius
    Health Check & Troubleshooting: Version 1.2.6 by The WordPress.org community
    Imagify: Version 1.8.4.1 by WP Media
    Jetpack by WordPress.com: Version 7.1.1 by Automattic
    LayerSlider WP: Version 6.8.2 by Kreatura Media
    Loco Translate: Version 2.2.1 by Tim Whitlock
    ManageWP – Worker: Version 4.7.7 by GoDaddy
    Redux Framework: Version 3.6.15 by Team Redux
    Responsive for Visual Composer: Version 2.3.5.1 by BestBug
    Responsive Pro: Version 1.0.8 by BestBug
    rtMedia for WordPress, BuddyPress and bbPress: Version 4.5.6 by rtCamp
    Theia Sticky Sidebar: Version 1.8.0 by WeCodePixels
    WordPress GDPR: Version 1.7.2 by DB-Dzine
    WordPress Popular Posts: Version 4.2.2 by Hector Cabrera
    WPBakery Page Builder: Version 5.7 by Michael M – WPBakery.com
    WP Rocket: Version 3.2.6 by WP Media
    Yoast SEO: Version 10.0.1 by Team Yoast

    ### Media handling ###

    Active editor: WP_Image_Editor_GD
    Imagick Module Version: Imagick not available
    ImageMagick Version: Imagick not available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: 9.07

    ### Server ###

    Server architecture: Linux 3.10.0-714.10.2.lve1.5.17.1.el7.x86_64 x86_64
    Web Server Software: Apache
    PHP Version: 7.1.27 (Supports 64bit values)
    PHP SAPI: litespeed
    PHP max input variables: 1000
    PHP time limit: 30
    PHP memory limit: 256M
    Max input time: -1
    Upload max filesize: 2M
    PHP post max size: 8M
    cURL Version: 7.62.0 OpenSSL/1.0.2k
    SUHOSIN installed: No
    Is the Imagick library available: No
    htaccess rules: Custom rules have been added to your htaccess file

    ### Database ###

    Extension: mysqli
    Server version: 10.3.13-MariaDB
    Client version: 10.3.13-MariaDB
    Database prefix: wp_

    ### WordPress Constants ###

    ABSPATH: /home/adargon63/public_html/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Enabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

    ### Filesystem Permissions ###

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    This is a private community (https://le-cercle-des-papoteurs.org) requiring registration, if you provide me with your email address I could send you a private password to test.

    pa7

    (@sugar7)

    Just had a customer email to say the message is back. I have not changed anything on the wordpress end. Still php 7.1 and not using wordpress 5 yet..

    I have gone to add an event with and without an image and it is fine. Why is this so unreliable??? when will it be fixed?

    What are others using instead? I am fed up with the lack of replies and this not working more reliably. Thanks

    Plugin Support timrv

    (@timrv)

    Hello,

    Currently, only Devs have the date on when the next update will be available. I have already followed-up on our Devs on when it will be available. I’m using PHP 7.1 and I don’t encounter any Variable mismatch error.

    Could you perhaps post the specific message or screenshot that you see. Most of the time the error states the specific file that is causing the issue. If possible it would be more helpful if you could provide a link that We could see.

    pa7

    (@sugar7)

    the error message tells nothing of use!! I have asked about this in the past without reply…

    https://drive.google.com/open?id=1dY7iHgL5y2bYxEsvVvTURHd1RTg4jPuI

    Plugin Support timrv

    (@timrv)

    Hello,

    Could I perhaps know your full versions of the following?

    1. WordPress
    2. PHP
    3. EM Versions

    Just want to make sure, Does it still happens when theme activated is any of twenty series and the only plugin activated is EM?

    My test system is:

    WordPress: WordPress 5.1.1
    PHP: PHP 7.1
    EM: Latest versions. 5.9.5 and 2.6.4

    So far I don’t encounter those issues.

    Kristian Yngve

    (@kristianngve)

    Hi all, Seems like I’m getting this “A variable mismatch has been detected.” error too, and yes, it happens ONLY when I attach an Event Image.

    Here’s my screenshot: https://prntscr.com/ndc7ev

    How to switch back to using PHP 7.1. ? But I am on a much lower PHP version for some reason and I always update WP…. any useful guides on that? Thanks!

    1. WordPress: 5.1.1
    2. PHP: 5.6.40
    3. EM Versions: 5.9.5 (Pro: 2.6.4)

    pa7

    (@sugar7)

    yes, 3. is the latest 5.9.5 – others as specified above (not sure why you have another number i.e. 2.6.4 – what is that for..?

    can the error messages be improved to tell what is the cause of the error?

    I cannot change the theme and uninstall all plugins..

Viewing 15 replies - 16 through 30 (of 55 total)
  • You must be logged in to reply to this topic.