Support » Fixing WordPress » a technical issue as soon as I got started

  • As I finished installing the wordpress I first deleted the default plugins and change the permalink, and then the parts of the themes are bugged and only shows the raw html code now.
    I tried to deactivating/deleting all the plugins, changing the themes and removing all the caches but it did not work.

    I also received an email like this

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with your theme, PopularFX.

    First, visit your website (https://curatepost.com/) and check for any visible issues. Next, visit the page where the error was caught (https://curatepost.com/wp-admin/customize.php?theme=popularfx&return=https%3A%2F%2Fcuratepost.com%2Fwp-admin%2Fthemes.php%3Ftheme%3Dpopularfx) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    https://curatepost.com/wp-login.php?action=enter_recovery_mode&rm_token=12yFqb7G8d7jNk3S1SjfAR&rm_key=SiNjQLTdTuydrtaPXk8Uez

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.5.1
    Current theme: PopularFX (version 1.1.4)
    Current plugin: (version )
    PHP version 7.4.11

    Error Details
    =============
    An error of type E_ERROR was caused in line 293 of the file /home1/curatost/public_html/wp-content/themes/popularfx/inc/customizer.php. Error message: Uncaught Error: Call to undefined function pagelayer_livelink() in /home1/curatost/public_html/wp-content/themes/popularfx/inc/customizer.php:293
    Stack trace:
    #0 /home1/curatost/public_html/wp-includes/class-wp-hook.php(287): popularfx_customize_register(Object(WP_Customize_Manager))
    #1 /home1/curatost/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #2 /home1/curatost/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #3 /home1/curatost/public_html/wp-includes/class-wp-customize-manager.php(933): do_action(‘customize_regis…’, Object(WP_Customize_Manager))
    #4 /home1/curatost/public_html/wp-includes/class-wp-hook.php(287): WP_Customize_Manager->wp_loaded(”)
    #5 /home1/curatost/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #6 /home1/curatost/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #7 /home1/curatost/public_html/wp-settings.php(568): do_action(‘wp_loaded’)
    #8 /home1/curatost/public_html/wp-config

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • The error shows in the function pagelayer_livelink() in popularfx theme.

    My guess is that some of the plugins you deleted are actually required by the theme to operate properly. I would re-install and try again.

    Or, start debugging in the /public_html/error_log file

    https://wordpress.org/support/article/debugging-in-wordpress/

    So the problem, as reported in the error message you posted, seems to be coming from the PopularFX theme.

    If you’re able to access the admin panel, kinly switch to the default theme and let’s see what happens.

    If you’re unable to access the dashboard, please access your website’s files (via FTP or your hosts’ web-based control panel) and remove/rename the PopularFX theme’s folder to deactivate it.

    By the way, I’m not sure how this relates to the error message reported by WordPress, but it seems you’ve switched your site to HTTPS, but SSL is not properly implented on your website. This makes your site completely inaccessible, and this has nothing to do with the error message WordPress sent.

    I can open your homepage at http://curatepost.com/ (note this is http, not https). But all links on the page redirect to https and this doesn’t work. Google Chrome reports “ERR_SSL_UNRECOGNIZED_NAME_ALERT”. Did you actually install install an SSL certificate for your domain name curatepost.com before switching to HTTPS?

    Thread Starter teitei

    (@teitei)

    I decided to reset my webpage using a reset plugin since I thought it’ll be quicker as I haven’t wrote anything on my webpage yet.
    It seemed working yesterday but when I tried to login to my webpage and I could not find
    I used Hostgator to set up my website and it is possible that the SSL was not implemented on my website properly.
    Now I can’t access my original URL https://curatepost.com and only can access http://curatepost.com
    I was following a youtube tutorial one by one and I have no idea how this is happening.

    Thread Starter teitei

    (@teitei)

    One thing I found out is that when I tired to disable all the plugins and themes by changing the file names, the appearance of the webiste http://curatepost.com stayed the same. I don’t know if it helps.

    I’m considering completely uninstalling wordpress from hostgator and reinstalling wordpress again.

    Thread Starter teitei

    (@teitei)

    I reinstalled the wordpress from my Hostgator and the webpage seems fine but the address is now http and not https, and I cannot login to my wordpress even when I type “/wp-admin” or “/login” after that.

    Do I have to buy a SLL certificate from the host or am I doing something wrong?

    When I first implemented the website I’m pretty sure the address was https and I could log into my website without any problem

    Looms like your admin is still redirecting yo SSL version.

    Try incognito mode – there might be some caching issues remaining that are causing redirects to SSL.

    SSL might be paid, it depends on the hosting company. In cpanel, go to SSL/TLS status and if button “run autossl” is there, click it and you get free SSL. If not, chances are host gator will hake you pay for it.

    Check the errors presented.

    E.g. when going to WP-admin the page shows:
    ERR_SSL_UNRECOGNIZED_NAME_ALERT

    The word SSL gives it away…

    • This reply was modified 7 months, 3 weeks ago by SJW.

    Hello,

    Sorry, I’ve been away from my desk 😀

    I reinstalled the wordpress from my Hostgator and the webpage seems fine but the address is now http and not https, and I cannot login to my wordpress even when I type “/wp-admin” or “/login” after that.

    No, the address in WordPress is STILL https. While you can visit the front-page of the site with HTTP, the address configured in WordPress is still HTTPS. That’s why you still cannot login, as you don’t have an SSL certificate installed for your domain

    To test this, simply click on any link on your site… and check your error message displayed by your browser.

    Do I have to buy a SLL certificate from the host or am I doing something wrong?

    You need to acquire and install an SSL certificate. Whether you need to buy it or you get it for free really depends on your host. But in this day and age, most of even the cheapest shared hosting providers provide a basic SSL for free. I don’t know about Hostgator, though I can see on their website that free SSL is included in all hosting plans.

    I’ll advise you to get in touch with your host (Hostgator) and ask about how you can use the free SSL certificated supposedly included in your hosting account.

    Good luck!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘a technical issue as soon as I got started’ is closed to new replies.