Support » Plugin: Uncanny Automator - Automate everything with the no-code Automation tool for WordPress » A tag is added to a user trigger not work when I add a tag to a user

  • Resolved petkesistvan

    (@petkesistvan)


    Hi!
    Does the “A tag is added to a user” trigger not work when I add a tag to a user within an Automation Funnel in Fluent CRM, automatically.

    I see that the “A tag is added to a user” and “A user is added to a list” triggers ONLY work when I manually add a tag to a user or add it to a list.

    However, it does not work when in Fluent CRM within an Automation Funnel, one of the actions is to Apply a Tag to a User or Apply a List to a User.

    Please fix this, as it would be important to have it work automatically and not have to manually tick thousands of users to get a tag.

    Thank you very much in advance for your help.
    Anyway, Uncanny Automator is a very good plugin, I really like it 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Uncanny Owl

    (@uncannyowl)

    Hi @petkesistvan ,

    Thanks for your patience. This was a pretty complex issue; the Fluent automation (on their side) can run without a user being logged in, and if it’s part of the registration, we only see the user information AFTER the tag is applied. Basically, Automator could pick up that the tag was added, but because of the workflow behind the scenes in Fluent, we were getting passed a null user record.

    We had made 2 files available to you here to help with this issue: https://we.tl/t-MXgcWOCrWs

    The files should be uploaded to your site by FTP, replacing existing versions, at these paths:
    uncanny-automator\src\integrations\fluent-crm\triggers\fcrm-tag-added-to-user.php
    uncanny-automator\src\integrations\fluent-crm\helpers\fluent-crm-helpers.php

    We’ll include these changes in the next release. Let us know though if you still have trouble after these changes.

    Thread Starter petkesistvan

    (@petkesistvan)

    Dear @uncannyowl ,

    Thank you very much for your help.
    I thought it was not an obvious thing.

    And thanks for the files, I’ll try it tomorrow and get back to you if you like.

    Thread Starter petkesistvan

    (@petkesistvan)

    Dear @uncannyowl ,

    I tried the files you sent.
    I see that they work very well.
    Now, it works “A tag is added to a user” trigger, even when Fluent CRM Automation Funnel adds the tag to the user.

    So thank you very much for your help.

    Will this also work for the “A user is added to a list” trigger?

    Plugin Author Uncanny Owl

    (@uncannyowl)

    Hi @petkesistvan , we released the Automator update a few minutes ago that include the changes you confirmed are working for you now. I’ll go ahead and mark this issue as resolved since the fix has been released.

    For your question about the other trigger, it should also work, but it wasn’t one of our test cases for the release. If you are still seeing an issue definitely let us know and feel free to reopen the ticket.

    • This reply was modified 2 months ago by Uncanny Owl. Reason: missed word
    Thread Starter petkesistvan

    (@petkesistvan)

    Hi @uncannyowl,

    I see it works fine when “A tag is added to a user” trigger, even if Fluent CRM Automation Funnel adds the tag to the user.

    Thank you very much.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.