WordPress.org

Ready to get started?Download WordPress

Forums

A question to PostgreSQL database users (3 posts)

  1. not1_name
    Member
    Posted 3 years ago #

    I have been running version 2.9 using the PG4WP plugin to run a PostgreSQL database. I never upgraded my wordpress to the latest version as this plugin was only for versions up to 2.9. I noticed that this plugin is now compatible with 3.2.1 and so updated to the latest version of wordpress. After an error issue I updated to the latest version of the plugin and can now view my blog fine.

    The problem is that when I login I get the "Database Update Required" message. As my database is not MySQL, I don't know what running the database update will do. I can't find an answer to this on the Net. Could anyone using PostgreSQL, who has done an update, let me know the correct proceedure?

  2. hawk__
    Member
    Posted 3 years ago #

    PG4WP is intended to handle database upgrades correctly.

    Although you should do a backup before you run the upgrade (we never know what could go bad), you can run the upgrade.

    You'll get some error messages in your postgresql logs, due to WordPress trying to recreate already existing indexes (WordPress thinks they don't exist yet), they can be safely ignored.

    The Hawkix Blog (http://www.hawkix.net home of PG4WP) is running the latest release of PG4WP and was upgraded smoothly from WordPress 2.9 to WordPress 3.2.1

  3. not1_name
    Member
    Posted 3 years ago #

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic