Support » Plugin: Contact Form by BestWebSoft » A problem with email sender

  • Resolved xprt007

    (@xprt007)


    Hi there

    The other day, after a client complained about something that required immediate attention from the contact form, I hit the reply button and responded to the query.

    Then a day or 2 later, he wrote again but the response showed he had not read the email I sent.

    That is when I looked at the sent mail again & to my dismay, it had been sent back to me (website’s mail host), although admittedly in the original email, his particulars included his email address. It seems this has been happening for a while, but I stupidly not looked at these emails sent back critically to find out why.

    I looked at the settings again …
    When I tried to change the settings so we have what you say in this thread => https://wordpress.org/support/topic/reply-e-mail-direction?replies=3
    … so the email is shown to be coming from Send X & sender’s email, I got the warning “Notice: Email ‘FROM’ field option was changed, which may cause email messages being moved to the spam folder or email delivery failures.”

    And indeed, whereas the previous mails where being instantly, including a copy, none sent this time were delivered, not even as spam.

    I was using another contact form plugin I think called Fast contact form, before & it did not have this problem, but because I wanted reCaptcha, moved to yours.

    Is there any way, this can be corrected so this error does not come up, so one can simply use the “reply” button in the emails sent from the contact form, without having to manually copy & paste the users email & virtually write a new email to them each time, instead of “replying”?

    ##### Update ######

    Strangely, now with the settings:
    ‘FROM’ field Name => “User name” & Email => “Email”

    I get in the email as admin receive with header:

    From => Name (of website) <email of sender.com> & NOT expected “User name” of Sender!
    Trying to clear cache did not help.
    This does not sound right.

    Thank you in advance

    https://wordpress.org/plugins/contact-form-plugin/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter xprt007

    (@xprt007)

    ##### Update correction ######

    Strangely, now with the settings:
    ‘FROM’ field Name => “User name” & Email => “User email”

    I get in the email as admin receive with header:

    From => Name (of website) <email of sender.com> & NOT expected “User name” of Sender!
    Trying to clear cache did not help.
    This does not sound right.

    Thank you in advance

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Unfortunately, some servers can change or filter some data during the outcoming data sending (as a rule for security reasons). Please complete the following:
    1) Try to choose another email instead of the admin’s one (‘Use this email:’ block) – for example, gmail or similar.
    2) Try to specify your email – for example, gmail or similar in The email address settings in the ‘From’ field instead of User email.
    3) Try to install an extra plugin called SMTP by BestWebSoft (https://wordpress.org/plugins/bws-smtp/), and then configure it accordingly. When done, open the “Send A Test Email” tab on the plugin settings page, check an option “Display log” and send a test email. Then examine the plugin log for any errors after a test email is sent. If some errors occurred, you need to fix them. Note that it is necessary to set SMTP by BestWebSoft the same way your contact form is set before sending a message.

    Sincerely,
    BestWebSoft Support Team

    Thread Starter xprt007

    (@xprt007)

    Hi there

    Thank you for the response.

    The change I made from above under “What to use?” on the Additional Settings page was to change the default => Wp-mail (You can use the wp_mail function for mailing) to => Mail (To send mail you can use the php mail function) INSTEAD.

    Result: the message from the contact form was correctly shown to come from the “Sender” with the correct email of sender, so one can without any mistake click the reply button to reply & it will be sent to the contact form sender.

    The FROM’ field => has username & User email selected.

    IF you change back to “Wp-mail” with the same settings in other areas, not a desired result is got.

    So changing to => “Mail (To send mail you can use the php mail function”, solved the problem I had without doing anything else.

    Probably that may help someone with a similar problem. 😉

    Thank you & kind regards.

    Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Thank you for your reply.
    We are glad that everything is fine now.
    Feel free to contact our support team with any questions in future.

    Sincerely,
    BestWebSoft Support Team

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘A problem with email sender’ is closed to new replies.