Support » Plugin: All in One SEO Pack » A post’s update/writing page freezes

  • Resolved setevoy

    (@setevoy)


    After some upgrade, not sure which one, but 1-2 months, when writing or updating a post, especially when it’s big – the whole page freezes for 10-20-60 seconds.

    Reproduces in Firefox, Chromium, Brave browsers.

    This makes almost impossible to use the plugin.

    I have to disable it in Plugins, then write/update a post, and then enable the All in one SEO back again.

    My assumption is the Preview snippet below a post, which generates a preview on a fly.

    Anybody else faced with such a (huge!) problem?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor arnaudbroes

    (@arnaudbroes)

    The Preview Snippet code couldn’t cause this. Also, it’s been refactored in the latest version of the plugin. I’d recommend following these troubleshooting steps here to make sure it isn’t a conflict – https://semperplugins.com/documentation/how-to-troubleshoot-issues-with-all-in-one-seo-pack/

    I have the same exact issue of freezing, mainly with long worded pages (like Privacy Policy), updated everything and left AIO the older version. No issues if I don’t update this plugin

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @brandimor I’ve been able to reproduce the issue somewhat with a 25,000+ words post. I see that the page hangs for a split second before the Preview Snippet is updated. I’m working on a fix now and we’ll release it soon.

    Hi, @arnaudbroes

    Thanks for your reply.
    For me, it happens for example even with the post with 2500 words.
    Please, check the screenshot below.

    Freeze && 100% CPU on editing

    (didn’t try to disable other plugins – just had no time yet for more deeper debugging yet, sorry)

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @setevoy I’m afraid that I’m not able to reproduce it with such a low amount of words. If you’d like us to take a look, then please contact us here – https://semperplugins.com/contact/support-login-information/. You can enter the URL of this page where it asks for a license.

    setevoy

    (@setevoy)

    @arnaudbroes Here is why I suggested that the issue is because of the Preview snippet – pay attention, that in this case, it generates a preview with the WHOLE content of the post’s text: screenshot.

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @setevoy we have a fix for this in the works and it should be released somewhere early next week. I can’t say whether that would solve the other issue you’re experiencing but definitely let us know in case it does not.

    setevoy

    (@setevoy)

    @arnaudbroes Great, thank you.
    I just now noticed the “Description” filed length, although I’m pretty sure you already aware of this behavior (I won’t’ use the “bug” word here yet 🙂 ).
    The screenshot is here – check the “Description” at the bottom – it also has the full text included.

    Plugin Author wpsmort

    (@wpsmort)

    @setevoy Please contact us here https://semperplugins.com/contact/ as we cannot reproduce this on any site here. Use the URL for this topic in the License Code field.

    I am experiencing this problem too.
    When the post gets longer than a few hundred words, lag appears. Going on writing, it gets longer, until it seems to have no end.
    In the italian WP forum I had the kind support by @arnaudbroes, but regretfully he has not been able to reproduce the issue, so it is still there.
    The funny thing is that while I meet this problem with an A4-5000/8 GB RAM/W10 HP Pavilion laptop, that is the one I prefer for writing and works perfectly for anything else, even heavy applications like Photoshop, with an i5-7200/8GB/W10 HP 255 G6 laptop the problem does not appear.
    Followed a discussion on Github but really too cryptic for my skills.
    Did not see any update recently.
    Will try the disable-write-reable trick, even if it is a bit boring, especially when a post can be completed only after many writing sessions.

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @clack we’ve got a fix for the issue and will release it this week.

    Great!

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.