Support » Fixing WordPress » A new 500 internal error

Viewing 15 replies - 1 through 15 (of 21 total)
  • Do you have access to error logs? If so, check the logs for your web server to see if they can give more details as to the source of the error.

    I would check permissions for your WordPress files. Directories should be 755 and files should be 644.

    Try checking your site’s error logs for a more specific error message. Your hosts should be able to help you in accessing your site’s error logs.

    The cause may be server configuration. To test it;
    -remove/rename the .htaccess file in the root path (like, a.htaccess)
    -create an html file in the root path, let’s say test.html
    Try to access test.html file;

    If you’re still getting the error code 500, contact your hosting provider.

    A HTML file does work.

    I tried removing the htaccess still no luck.

    The file permissions are all set right.

    Any other suggestions?

    Moderator Andrew Nevins


    Volunteer support

    Any other suggestions?

    Yeah, look at Esmi’s and Christiaan’s posts.

    I have done what they have suggested.

    A HTML file does work and show up but I am still getting a 500 error on wordpress.

    Looks like its something to do with WP Commerce according to the error logs

    File does not exist: /var/www/vhosts/

    If the bug is present even with WP Commerce deactivated, it’s unlikely :-/

    I doubt that will solve the problem but you have nothing to lose here, as long as you make a bulk-ftp-download backup… Can you delete all the core wordpress files (/wp-admin/ and /wp-includes/) and reupload them from a fresh archive provided by ?

    The file rights, are you *sure* they’re good ? Best way to make sure :

    find /home/your_files_folder/public_html/ -type d -exec chmod 755 {} \;
    find /home/your_files_folder/public_html/ -type f -exec chmod 644 {} \;

    Our host has suggested it might be a mysql call loop problem.

    I can see that when the site is being run it is generating an sql query as mysql is using up loads of resources on the server. As such it looks like a script issue which is generating a never ending loop or mysql call which is the issue.

    I have set file permissions as suggested as well by the way.

    Any ideas what could cause a loop?

    Impossible to say that this stage. Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    Yep done both of those things already once I made sure the permissions were correct. Still no luck.

    This is the error being kicked out from the server:

    [Mon Aug 12 15:35:10 2013] [warn] [client] mod_fcgid: read data timeout in 45 seconds
    [Mon Aug 12 15:35:10 2013] [error] [client] Premature end of script headers: index.php

    Did you delete all files and folders except the wp-content folder, and upload a fresh copy of WordPress (except wp-content)?

    Yep done that as well the other day.

    How exactly did you reset the plugins folder?

    Re-named plugins as well as doing via phpmyadmin

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘A new 500 internal error’ is closed to new replies.