Support » Plugin: BruteProtect » A must use plugin!

  • Every WordPress site should have this plugin in their security suite. In the past week it has blocked about 250 login attempts on two of my sites.

  • The topic ‘A must use plugin!’ is closed to new replies.