Support » Plugin: WooCommerce Stripe Payment Gateway » A lot orders is failed

  • Resolved raivydas

    (@raivydas)


    Hello, I didin’t know what to do, because I lost a lot of orders. In order details I see order note – “The card was declined.”
    But in stripe I see decline code is do_not_honor. I didin’t know what to do, because in dcember half everything was fine.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    This is actually a good thing. The card was declined by Stripe and the actual reason is “do not honor”. This is an example of Stripe protecting you and your site by not processing payments that it can’t be sure of. It’s likely that these orders are people trying to spam or scam your site.

    As long as there’s a clear reason such as “do not honor”, everything is going exactly as it should.

    Thread Starter raivydas

    (@raivydas)

    But there is a lot of orders. And I see that is real persons, not a robot or something else. They can’t do a checkout.

    Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there

    But there is a lot of orders. And I see that is real persons, not a robot or something else. They can’t do a checkout.

    Stripe is saying that they can’t process the card – that’s something that Stripe is deciding on your end. As I mentioned, this is normally a good thing. However, if you need more information on exactly what’s going on, your best option is to talk directly with Stripe:
    https://stripe.com/en-se/contact

    Thread Starter raivydas

    (@raivydas)

    I contact with them not one time. They said to me, that it’s problem with customers banks. I think something is bad with my site or plugin, because in the past I didin’t see any failed orders, it’s start to me on 17 december. In the past I get more orders than now, and no one failed… I didin’t understand what is the problem with my webiste or plugin.

    Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Thanks for that update!

    They said to me, that it’s problem with customers banks

    That reflects exactly what the Stripe dashboard is saying – Stripe is denying the payments because they’re receiving a “do not honor” message from the banks.

    If you use a different Stripe plugin, then you should receive the same exact response. It’s not the plugin making the decision on whether to take payment, but Stripe itself.

    Otherwise, you may want to consider using a different payment method. For example, have you had a look at PayPal? They use different algorithms to determine whether or not to accept payment.
    https://woocommerce.com/products/woocommerce-gateway-paypal-checkout/

    With that being said, if Stripe is denying the payments, then I’d trust Stripe. They’re denying the payments to keep all of us safe and make sure that payments are trustworthy.

    Thread Starter raivydas

    (@raivydas)

    I understand that in this situation no one can help to me. My customers write to me why they can’t make a payments and get a products. They say that in others shops card working very well, and everything is fine.

    Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there!

    As a shop owner, it’s up to you to figure out what works for you. This isn’t a problem with the Stripe plugin as such — there isn’t anything we can do to help you solve this as Stripe is declining the payments I’ve offered a few concrete suggestions for next actions in my previous response. Your best option is to take a look through them and decide what you’d like to do next.

    Thread Starter raivydas

    (@raivydas)

    Hi, again. Thank You for information.
    I talk again with stripe and I get a information from them, there is them message to me: I dig further to identify what seems to be the issue with the increase numbers of the declined payments on your account. I’ve found out from your dashboard logs that there is no payment method or source in the payment intent object when the API call was created. The solution is to create a payment method and attach it to customer object. I noticed that your integration is coming from WooCommerce.

    Could you please help me to solve this?

    Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    Thanks for sharing that info! That does sound odd and like something may not be going quite right with the plugin.

    Could you please share a copy of your site’s System Status? You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”.  Once you’ve done that, paste it here in your response. You can remove the identifying info such as the site URL if you prefer.

    Thread Starter raivydas

    (@raivydas)

    Thread Starter raivydas

    (@raivydas)

    I see that I get this problem after plugin update, before decmeber 16 I didin’t get anyt failed orders, but after december 16, I get a lot failed orders. So I think that there is problem with plugin. And also there is a system report – https://pastebin.com/yQWpsgw0

    Plugin Support Hannah S. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    Thanks for sharing that info! On checking through, I noticed your site’s Stripe version:

    WooCommerce Stripe Gateway: by WooCommerce – 4.5.3

    The latest version is actually 4.7.0 from 22 December. Here’s the full changelog:
    https://raw.githubusercontent.com/woocommerce/woocommerce-gateway-stripe/master/changelog.txt

    Can you please update and see how that goes?

    To confirm: is every single order failing, or just some?

    Thread Starter raivydas

    (@raivydas)

    With this version is the same problem. Yesterday I downgrade this version, because I see that update was realised in december 16, and after that I get many failed orders. So same issue with 4.7.0 version.

    Not all orders failes, only some, about 30 procents

    • This reply was modified 1 month, 3 weeks ago by raivydas.
    Thread Starter raivydas

    (@raivydas)

    Hello, can you help me? And why in this page I see that it’s resolved? It’s not.

    • This reply was modified 1 month, 2 weeks ago by raivydas.
    Plugin Support Joey – a11n

    (@jricketts4)

    Hi @raivydas – Is this something you’re able to duplicate if you place a test order?

    If so, you may want to try updating Stripe again to the latest version, then try duplicating again. If the issue persists, that may call for a conflict test to ensure nothing is intervening in the checkout process making these orders look fake to Stripe.

    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Please let us know if the issue persists after following these instructions. 😁

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.