Support » Fixing WordPress » A lot of errors after wordpress backup

  • Resolved kubeq130

    (@kubeq130)


    Hello,

    3-4 months ago I installed an addon to optimize photos etc to make my site load faster. When this addon was working I got a big suprise – my website stopped working and I could not even login to wp-admin. So I make a copy of my files through FTP and installed new version of wordpress and then copied files from old wordpress. I did the same with database. After some time I updated one of my addons and got error like this:

    nt/plugins//wp-content/plugins/wp-hide-post/wp-hide-post.php): failed to open stream: No such file or directory in /wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4791

    Yesterday I added adsense code to my site and after saving file I saw:

    Warning: fopen(//wp-content/plugins//wp-content/plugins/wp-hide-post/wp-hide-post.php): failed to open stream: No such file or directory in /wp-includes/functions.php on line 4785
    
    Warning: fread() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4788
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /wp-includes/functions.php on line 4791
    
    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/functions.php:4785) in /wp-admin/post.php on line 197
    
    Warning: Cannot modify header information - headers already sent by (output started at /wp-includes/functions.php:4785) in /wp-includes/pluggable.php on line 1210

    I can’t even edit my post or even use a search engine in admin area. Is there any solution for this? Or I have to install new wordpress wersion and add my articles manually? I would like to avoid it, because I have really a lot of articles on my site…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello!

    From what I see, the WP Hide Post plugin is causing this. You need to deactivate it and the problem should be solved.

    If you want to find a fix for that error, you should ask for help here – https://wordpress.org/support/plugin/wp-hide-post

    Thread Starter kubeq130

    (@kubeq130)

    Ok, I disabled but I see a lot of other errors when I only try to install some new addon or something. Other old addons are causing some problems too. Now for ex. I installed: https://wordpress.org/plugins/adsense-in-post-ads-by-oizuled/

    And after inserting an ad I got error on my main site:

    Notice: Use of undefined constant AMP_QUERY_VAR - assumed 'AMP_QUERY_VAR' in /wp-content/wptouch-data/extensions/amp/wp-amp/includes/amp-helper-functions.php on line 36

    @kubeq130 I’m the developer of the AdSense plugin you mentioned, and I can confirm that AMP_QUERY_VAR is not a constant included in that plugin. The error appears to be coming from whatever the wptouch-data is in your wp-content directory. Try removing that to see if the error goes away.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘A lot of errors after wordpress backup’ is closed to new replies.