Support » Plugin: Product Catalog » A few things I need to figure out

  • Resolved therealcrazy8

    (@therealcrazy8)


    I am trying to meet a tight deadline, but I have a few issues I need to sort out and I am hoping to get a bit of help with them. All of them pertain to the /shop page.

    1. If I hit on the text, product picture, or “read more” for any of the products, I want to be directed to the single product page for that product, and then from there be able to do the “add to cart/check out” stuff there as well. I am assuming the page that it takes me to now may be coming from my woocommerce, but how can I correct the behavior so that when the product text, picture, or the “read more” text is clicked, that it goes to the single product page? It used to do that early on when I was setting this up, but I am unsure of what happened.

    2. If you are on the /shop page and scrolled all the way up, you can see, after adding a product to the cart, that even though the shopping cart icon shows up, the “Checkout or empty cart” box is covered and all I see is the lower half of that box and “or empty cart”. Of course, once you scroll down the page, you’ll see the full thing, but I would like customers to notice it right away like they should.

    However, if I put in /shop/?SingleProduct=2 you will see that I do in fact go to a single product page. Oddly enough, if you hit “back to catalog” from that page, it will take you to my home page, but the link in the browser will have “/?SingleProduct=2” at the end.

    If I could get these taken care of, I am pretty sure I be able to launch come 1/1/2019. Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • ***UPDATE***

    1. I have now solved this issue. I guess the only problem I have with this is that the single product page not only takes me to a page that is a default woocommerce design, but also shows the “Related Products” which I want to remove ( along with the drop down menu’s) and I have not been able to find out how. From what I can tell, it is disabled in UPC though.

    2. This is also solved now. The first half of this issue anyway. I found that there was a setting that needed to be changed so that it would attach to the menu.

    In regards to to the /?SingleProduct=2 part, doing that will take you to a single product page that appears different than the woocommerce looking one. If I were to want to use this style instead (not sure if I do want to use it or not yet) how would I go about doing that?

    Thank you

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi therealcrazy8,

    You could disable the option “WooCommerce Product Page” by navigating to the “WooCommerce” area of the “Options” tab, this will redirect the user to the “product page created by “Product Catalog” and not “WooCommerce”. The settings regarding the “Related Products” would affect only the product page generated by our plugin and not by WooCommerce.
    You would need to re-save the permalinks structure to avoid getting 404 errors after setting the “WooCommerce Product Page” option. You can do so by going to the “Settings” -> “Permalinks” from the “WordPress” admin sidebar, just click on the “Save” button without actually making any changes.

    The above suggestion answers point 2 as well, the “SingleProduct” page is indeed the one generated by our plugin. All the styling and options you set for the product page would affect this product page which is completely customizable.

    Thank you for your help and all of that info. I did take a look at the “Woocommerce Product Page” setting, and I did/do have that turned off, but the pages that look like they’re a Woocommerce default design (but this is the one that is generated by UPC?), are what’s showing up when I click a product link in the catalog.

    I did do the “save” on the permalinks as you recommended. I am guessing that since I am still seeing the “Related Products” on the bottom of the catalog page and single product pages that it must be coming from woocommerce than?

    ***UPDATE***
    I was able to remove “Related Products” at the bottom of each single product page by adding:
    /* Remove WooCommerce Related Products */
    add_filter(‘woocommerce_product_related_posts_query’, ‘__return_empty_array’, 100);
    in the functions-enfold.php However, I still have that issue on the products catalog page

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi therealcrazy8,

    If you navigate to the “Premium” area of the “Options” tab and set “Related Products” to “None”, do you still see the related products on the product page?

    After disabling the related products from the product settings if you still see the related products on the UPCP product page, it could be due to a few reasons. Firstly, you could try clearing the cache of your caching plugin and see if that makes a difference. If not, could you please disable WooCommerce product pages and share a link to one of your product pages so that we could suggest you some custom CSS to hide the related products div.

    I have had “Related Products” set to none, and had “WooCommerce Product Page” disabled this whole time. Iv’e also cleared the cache multiple times as well. That’s why it seems so odd to have this issue. The individual product pages are fine now. But I still see stuff on the very bottom of my “shop” page.

    Thank you so much for your help.

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Your products are still linking to the WooCommerce product page, so, either that setting has to be enabled, or you have some other WooCommerce extension that is exhibiting a seriously weird conflict (because no WooCommerce anything should affect our catalog).

    Please go to the WooCommerce area of the Options tab and enable WooCommerce Sync. Then Save. This will allow you to see all the WooCommerce options. Then disable the “WooCommerce Product Page” setting. Then Save. Then disable the WooCommerce Sync. Then Save. Then check your catalog again to see where the products link to.

    If you have any caching plugins, make sure to clear the cache, or, better yet, temporarily deactivate them, to ensure that you are seeing the new output of the catalog.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘A few things I need to figure out’ is closed to new replies.