Support » Plugin: Salt Shaker » A few problems

  • Resolved Roberto Jobet

    (@robertojobet)


    Hi,

    Just installed the plugin.

    1) Clicking “Change Now” button doesn’t log me out, instead an error message is displayed “Not available” (url remains stucked at WPsite/wp-admin/tools.php?page=salt_shaker)

    2) Checking changes in wp-config.php

    All Keys and Salts values are changed but AUTH_KEY and AUTH_SALT. They remain exactly the same as the previous ones…

    Any idea?

    Thanks
    Best regards

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Nagdy

    (@nagdy)

    Hi @robertojobet
    I think CRON jobs are not working on your server. Would you like to try adding the following to your wp-config.php file

    define(‘ALTERNATE_WP_CRON’, true);

    right above the line in wp-config.php that says, “That’s all, stop editing! Happy blogging”.

    Hi @nagdy,

    Why do you say that it could be a cron problem? I haven’t set any scheduled job for automated Salt changing, I’m just using the “Change Now” button.

    Regarding the first issue, the problem was due to a security plugin that blocked the redirection to the login page.

    I’ve installed the plugin into another site and the output is the same. The AUTH_KEY and AUTH_SALT are not changed, they remain the same as the previous one.
    Your script should change every key and salt from the wp-config.php file, right?

    Best regards

    Plugin Author Nagdy

    (@nagdy)

    Hi @robertojobet

    Thanks for the feedback and sorry for my suggestion! I got confused and I thought you have a problem with the scheduled jobs.

    About the keys, I’ve tested on 3 different sites and all keys and salts are being changed correctly.

    Can you please replace the keys manually from https://api.wordpress.org/secret-key/1.1/salt/ and then try the plugin again? (I know it happens on 2 different sites for you but let’s start with a fresh set of keys)

    Hi @nagdy,

    I replaced the keys with WP API site and now everything works fine.
    Now I’ll try with a scheduled job.

    The only issue with your plugin, is that I cannot change login url with a security plugin as I usually do. I have to disable this feature, in order to use the default login url (wp-login.php).
    I’ve noticed that your plugin redirects to an unusual url:
    https://example.com/wp-login.php?redirect_to=https%3A%2F%2Fexample.com%2Fwp-admin%2Ftools.php%3Fpage%3Dsalt_shaker&reauth=1

    Any idea on how to solve this?

    Thanks and keep up with the good work!!

    Best regards

    Plugin Author Nagdy

    (@nagdy)

    @robertojobet actually, the plugin does not redirect to anything. I’m using JS to reload the page and WordPress is the one responsible for the redirection.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘A few problems’ is closed to new replies.