Support » Plugin: WPtouch » A few issues

  • Hi,

    First of all thank you for the plugin. I love it! I am having a few issues though I was hoping you would be able to help me with.

    1) Whenever I try to post a comment it doesn’t post it and says that it is too short, regardless of the length. How can I turn this off or fix it?

    2) I use a plugin called EasyRecipe that displays recipes. My (and other people who use both plugins) recipes are being cut off. Is there anyway you could point me in the right direction with this issue?

    3) My recipe page at has a really strange formatting. The title has a border, the mobile theme on/off bar is covering part of it, and the footer is inside the content. This probably has something to do with the WP Post Columns plugin I am using on the page. Is there anything I can do to fix this?

    4) Finally, is there any option to order the pages in the menu based on page order in the wordpress settings? This order is different from my ID order.

    Thanks so much for your help! Your plugin is great 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • Still stuck. Not sure what to do.



    Plugin Author BraveNewCode Inc.



    1. Please make sure you are using the latest version of WPtouch (, which should include a fix for the behavior you describe.

    2. What exactly is the issue? If possible, please share the URL of a page/post where we can clearly see what is happening.

    3. Can you verify that it’s the columns plugin by briefly deactivating it? You can also try activating “WPtouch Restricted Mode” via the WPtouch admin panel and see if that helps.

    4. This is only supported in WPtouch Pro at this time. WPtouch Pro supports custom WordPress menus that will allow you full control of the menu items and their order in the WPtouch Pro menu(s).

    You’re welcome.


    1. I am using the newest version 🙁 see screenshot:

    2. I changed some settings on EasyRecipe which makes it okay on mobile but not as nice on desktop, but it’s okay for now. Thanks.

    3. I turned off the column plugin and the issue disappeared in WPtouch Restricted Mode.

    Thanks for your help!


    Actually, for EasyRecipe, you can see the problem if you look at this post in mobile and desktop

    The mobile and desktop version looks quite different.

    Plugin Author BraveNewCode Inc.


    Hi Ilan,

    1. Did you check for plugin conflicts with another plugin by deactivating your other active plugins one at a time briefly to see if you find a culprit? If not, please do so and let us know what you find.

    The difference seems to be only in styling, and not content. You can take a look in the stylesheet of the plugin you’re using for the recipes and add it to the “Stats & Custom Code” section in the WPtouch admin panel.

    You’re welcome.


    I am unable to deactivate all my plugins because a lot of them are older and don’t save the information. Is there any other way to find the problem?

    The plugins I use are:
    akismet, all in one SEO pack, clean options, columns, comment reply notification, easy recipe, exclude pages from navigation, feedburner feedsmith, google XML sitemaps, header and footer, imagemagick engine, image widget, jQuery pin it button for images, KB advanced RSS widget, linkable title html and php widget by peplamb, remove image links, ultimate google analytics, wordpress database backup, wordpress popular posts, wordpress related posts, and wptouch

    Thanks for your help,


    I took your suggestion of adding the CSS to the Stats & Custom code but I can’t get it to work. For example, I added this code:

    #content .easyrecipe .ERSIngredients li.ingredient, .easyrecipe .ERSIngredients li.ingredient {
    list-style-type: none !important;

    to remove the numbering from the instruction items. This worked in the main site, but not on the mobile version since it is still numbered.

    I’ve been playing around with it some more and still no luck. Arg. 🙁

    Okay, I updated to the newest version of WPTouch. It no longer says that the comment is too short.

    Now, if there is a URL in the website field, the cursor moves to it when I press publish instead of publishing. If there is no URL, then it brings me to a 404 page because it brings me to while it should be /wordpress/wp-comments…

    Any CSS code added to the custom code section a) doesn’t affect anything and b) appears at the bottom of the page.

    e.g. this code is now at the bottom of the page:

    .ERSSectionHead {
    font-weight:bold !important;

    I am having trouble using the States & Custom Code feature. Whenever I add CSS, it just show up at the bottom of the site. I think I’m adding it incorrectly. This is what I’m doing

    Okay, so for anyone else who has this problem in the future what I did was go into the WPTouch style.css and add my own styling for easyrecipe. Unfortunately just putting that CSS code into the stats & custom code section (or linking to a stylesheet) doesn’t seem to work for me.

    with regards to commenting not working, I still have no idea what’s going on. Since the plugin redirects me to a non-existent page I don’t think it’s a conflict issue. Strange.

    Aha! I figured it out. I was right, it’s a glitch with the plugin.

    On comments.php the code says `<form action=”<?php bloginfo( ‘url’

    ); ?>/wp-comments-post.php” method=”post”


    even though my website is in a wordpress folder. I changed it to

    <form action="<?php bloginfo( 'url' 
    ); ?>/wordpress/wp-comments-post.php" method="post" 

    However, if there is a URL in the comment field, commenting does not work at all.

    Thankyou IlanK – I’ve been complaining about this comment posting issue for months now without any resolution. I recently discovered logging in doesn’t work either because WPTouch assumes my WP is in the site root (whereas it is actually in a subdirectory), so I was suspicious this might have been the problem with comment posting too. It seems my guess was right!

    For goodness sake WPTouch developers, please fix this very basic issue ASAP! WPTouch should work properly if a user’s WordPress installation is in a subdirectory.

    My unanswered bug report on login.php:

    I know, it’s such an awful bug! The code fix I suggested fixes commenting, but not if there is a URL in the URL field, which is really strange. Not sure why that is.

    You could probably make a similar change in login.php to get it to work until, of course, the next update.

    At least now this confirms that this is not because of another plugin interfering with WPTouch.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘A few issues’ is closed to new replies.