Support » Plugins and Hacks » W3 Total Cache » A disaster after the latest Upgrade

A disaster after the latest Upgrade

Viewing 15 replies - 16 through 30 (of 32 total)
  • After upgrading my WPMU-site was completely down. After deleting all w3-total-cache-config files and deleting `/** Enable W3 Total Cache */
    define(‘WP_CACHE’, true); // Added by W3 Total Cache` from the config.php everything functions normal again, accept for w3-total-cache.
    I’m hoping for a better upgrade…

    This is ridiculous. reversed back to

    The new dashboard is supposed to be the place for easy control, now it is the place the developer is peddling his services and news. There is no way to customize it.

    It is not broken, Don’t upgrade.

    I need to type something in here to unsubscribe from this post.

    My blog is still running, but wp-admin is dead.

    My server uses fastCGI.

    Stack trace:
    #0 …./wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error(‘/home/…’)
    #1 …./wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(421): W3_ConfigWriter->save()
    #2 …./wp-content/plugins/w3-total-cache/inc/functions/update.php(58): W3_ConfigWriter->import_legacy_config_and_save()
    #3 …./wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php(298): w3_run_legacy_update()
    #4 …./wp-content/plugins/w3-to in …./wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 117

    Same here. Borked. Trying to revert to the last version now.

    Totally buggered up my site.

    Have had intermittent problems viewing and logging into the site, sliders not working, widgets not loading in, running like treacle despite all the ‘enhancements’.

    Do you even bother to test the releases or do you just cross your fingers and hope?

    As someone who runs a commercial site I just can’t afford for a plugin to fail me on this scale.

    I have the same issue: I tried to do a fresh install:

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Uncaught exception 'FileOperationException' with message 'C:\inetpub\wwwroot\mysupercooldomain/wp-content/w3tc-config/master.php could not be created, please run following command:
    chmod 777 C:\inetpub\wwwroot\mysupercooldomain/wp-content/w3tc-config' in C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\inc\functions\activation.php:117 Stack trace: 
    #0 C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\lib\W3\ConfigWriter.php(159): w3_throw_on_write_error('C:\inetpub\wwwr...')
    #1 C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\lib\W3\ConfigWriter.php(421): W3_ConfigWriter->save()
    #2 C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\inc\functions\update.php(58): W3_ConfigWriter->import_legacy_config_and_save()
    #3 C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\lib\W3\Plugin\TotalCacheAdmin.php(298): w3_run_legacy_update()
    #4 C:\inetpub\www in C:\inetpub\wwwroot\mysupercooldomain\wp-content\plugins\w3-total-cache\inc\functions\activation.php on line 117

    Anyone have any solutions?

    @110101100, I had to sign in just to comment on your post. Do “you” even bother to test out plugins on a test site, prior to jumping right in on day one? For someone who runs a commercial site, I would think this would be an important first step.

    Let’s all remember something. This is a FREE product. Work through the problems, but there is no need to get downright nasty!!!

    Not everyone has the same WordPress host, the same plugins, the same this, the same that… So there is no way in he11 the author can create something with a “Standard” config.

    Just saying!

    Same issue with FileOperationException as most people here. chmod 777 doesn’t fix it.

    Edit: Solved by removing all traces of old version (including old plugin folder) and activating it again.

    I solved the problem recreating the missing files by hand.

    In the WPMU environment now is possibile to Activate Sitewide.

    The integration with newrelic is great.

    The update was too big.

    So I took the precautionary measure of
    1) clearing all cache
    2) uninstalling W3TC
    3) Clearing my browser’s cache
    4) clearing any left over files and directories (check your config file as well…I had changed permission and wouldn’t work automatically)
    5) optimizing the database
    6) Reinstalling “clean”

    When there are so many changes, and so many different setups, it’s better to play it safe. Something is bound to go wrong.

    I’ve only noticed an increase in time when serving non-cached pages I am not so enthused about (shared hosting), but still good.

    I also faced the same problem after upgrading..but what I did was uninstalled the plugin again it showed some errors and asked to delete some files ..i logged in to ftp and deleted those files in /public_html/wp-content/…. and also w3tc-config.php and w3tc folder …
    after that I logged into wordpress admin and installed the plugin again it worked…

    Like Ashwani Kumar Singh said.

    I too deleted all w3tc files, could access the website/backend and installed the plugin again. It works.

    Hello all, I totally agree with @noisegate95, most that use this plugin are very happy with the results and do everything within their power and ability to support this great plugin that is provided for FREE.

    Please to all who feel this is a waste of time and especially this huge or mega upgrade, there are always going to be problems with such an upgrade. Most of the time plugins do work. But bare in mind that a developer cannot test their new plugin or an upgrade against all host, all plugins and all templates out in the market.

    So please have some consideration for the developers of plugins and go ahead and THANK THEM for doing all of this for FREE.

    God bless you all………

    As I am waiting this one out, as I know I spent a lot of time tweaking and configuring W3 for optimal performance.

    I DID however install fresh on two test sites that did NOT have the older version and it went without an issue.

    For those users who are removing W3 and re-installing, I am assuming you are having to re-configure the plug-in from scratch or are you just restoring a W3 backup file?

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘A disaster after the latest Upgrade’ is closed to new replies.
Skip to toolbar