Support » Plugins and Hacks » W3 Total Cache » A disaster after the latest Upgrade

A disaster after the latest Upgrade

Viewing 15 replies - 1 through 15 (of 32 total)
  • Another problem is that on a WPMU environment the plugin is unusable.

    I can’t even seem to disable the plugin either.

    Fatal error: Uncaught exception 'FileOperationException' with message '<strong>/home/content/38/8595638/html/wp-content/w3tc-config/master.php</strong> could not be created, please run following command:<br /><strong style="color: #f00;">chmod 777 /home/content/38/8595638/html/wp-content/w3tc-config</strong>' in /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/inc/functions/activation.php:117 Stack trace: #0 /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error('/home/content/3...') #1 /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(421): W3_ConfigWriter->save() #2 /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/inc/functions/update.php(58): W3_ConfigWriter->import_legacy_config_and_save() #3 /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php(298): w3_run_legacy_update() #4 /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/lib/W3 in /home/content/38/8595638/html/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 117

    same here
    Cannot even access the dashboard. Giving all permissions to w3tc-config doesn’t help.

    I made the backend accessible again by commenting out (‘//’) line 117 in inc/functions/activation.php
    Certainly not the real solution, but at least we can access our posts.

    Yes and on WPMU environment the w3tc plugin is not visibile in the plugin list section, but active.
    Very strange.

    Same here, except only on three of 12 upgraded sites (different web hosts, though). Would be great to get this fixed, since the sites won’t survive without caching…



    Forum Moderator


    to report problems, please everyone start your own topic, and post as much relevant information as possible.

    this will make it easier to track the problems.

    Look here


    Everything is 777 and I filled in FTP credentials.

    Same issue on 2 website using mod_php.

    White screen after upgrading and impossible to create the various config file.

    Is there a way to create the files db.php etcetc manually?

    W3 Total Cache is one of the greatest WP plugins… but i was forced to restore my previous plugin backup after W3TC’s latest update… there were a few display issues which i’m a little too busy to work around now.

    @alchymyth Thanks for the advice! Until now I thought it would on the contrary make work easier for the developer if people who have exactly the same problem join one report.
    From my side there is no more information than what has already been mentioned.

    guys i think it changed the permission of the folder of wp-content to 3** something so i reverted it to 755 so far at least my subdomains seem to be functioning properly

    The same problem here, I just update w3 on 2 blogs and I couldn’t access the dashboard. I removed the plugin and install it again then when I try to activate the plugin I keep getting fatal error message

    Same here. This is the error I am getting.

    I’m having the same problem others describe here. I then tried deleting from the /wp-content/ folder the file w3-total-cache-config.php and the two folders /w3tc/ and /w3tc-config/. It didn’t fix anything. When I go to /wp-admin/ I get an error:

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /XXXXXXXXXXX/advanced-cache.php.

    I tried deleting that one as well, but then the error simply updated to the following:

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /XXXXXXXXXX/db.php.

    And after removing said file, it asked for:

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /XXXXXXXXXX/object-cache.php.

    And after deleting this last one, I was able to log in again. There doesn’t seem to be a sign of having W3TC installed anymore, but everything seems to be working fine. I’ll wait to read here in the forums for the best approach next, since I’m hesitant to reinstall W3TC.

    I upgraded the plugin on a PHP FASTCGI environment and everything is fine.

    I think there is a permission issue with w3tc and mod_php environment.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘A disaster after the latest Upgrade’ is closed to new replies.