WordPress.org

Support

Support » Plugins and Hacks » [Resolved] A Couple Problems….

[Resolved] A Couple Problems….

  • I am using 2 Font Squirrel fonts. There are 3 problems that I am encountering:

    1) When I input a selector or a series of selectors, and then save them, they do not appear in the input box when the page is refreshed. The interface leaves me to guess or try and remember what selectors I used for that font. Can the interface be made to refresh the selectors in use for that font?

    2) Because of the issues in #1, it appears that there is no way to delete the selectors in use for a specific font. If the interface showed the selectors and then allowed me to remove them and save, that would be ideal.

    3) The actual Font Squirrel fonts that I have chosen to use appear correctly in the CSS for the intended objects, however, the actual font is not correct. It is using Times New Roman or similar as a substitute. I have confirmed that the fonts downloaded and are in the fontmeister local directory. Even still, it does not work.

    Your plugin is a great one. And the inclusion of my own font kits in a future release would be fantastic.

    Thanks for assisting me with the problem I am experiencing.

    kcwebguy

    http://wordpress.org/extend/plugins/fontmeister/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Sayontan Sinha
    Participant

    @sayontan

    I cannot replicate issues 1 and 2, so I suspect you have a plugin that is conflicting with FontMeister and preventing some critical JS components from running. Basically FontMeister includes some JS and some CSS for the back-end, however those scripts are only included in the FontMeister admin pages – I have taken special care to ensure that they are not included in other plugins’ admin pages. Other plugins might not be taking the same precautions, and when you upgrade to WP 3.5, if those plugins break, the effects cascade into FontMeister’s admin pages.

    For #3, can you provide me with a URL to take a look?

    I have disabled all plugins except yours and still do not have the functionality that #1 and #2 describe.

    As far as #3, http://www.shoutcloudstudios.com/, if you use Firebug or a similar tool to inspect the words “Online Marketing” in the main content area in the center (NOT the left tab area) it reads h2.title {font-family: BebasNeueRegular;} but it does not render that font on the page.

    Below that you can see a previous rule that I declared in your plugin that is cancelled out: h2 {font-family: WebSymbolsRegular}. Again, I have no way to remove that style because of issues #1 and #2.

    Thanks for having a look.

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    Hmm… Unfortunately this isn’t something I can troubleshoot without looking at your site’s back-end.

    What is the best way to contact you privately to arrange for that?

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    I support my themes and plugins here: http://aquoid.com/forum. You will see an option to send me an email or a PM from the forum. Alternatively you can try sending me an email to my first name (Sayontan) at gmail.com.

    Login sent to your gmail via wordpress admin user setup.

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    OK. I am going to step out for a few hours. I will look into it as soon as I return.

    Thanks so much…

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    OK, I have fixed the problem. I will release the new version shortly, which you can upgrade to.

    That’s great. Thanks so much…

    Thank you for resolving items #1 and #2. I appreciate it.

    However, #3 is not resolved. It still does not render the correct font face. It is reverting to Time New Roman, it appears.

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    OK – looks like I missed that one. Regardless, here is a workaround that will do just fine. Go to FontMeister → Font Sources → Font Squirrel → Combine Font Squirrel CSS files, and set it to “Don’t combine”.

    That did it! Thanks for all of your help. I’m looking forward to your future work on the plugin. =D Have a nice day.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] A Couple Problems….’ is closed to new replies.