Support » Theme: Shift » A couple of WP 5.0 issues

  • So I’m using this with 5.0 RC 1 and wanted to report a couple of issues with the editor-styles.css file that are messing with Gutenberg.

    1. You need to remove the margin, padding and height values on the body element in that file. The margin and padding are messing with the top of the editor and making the permalink element hidden behind the top toolbar. The height: 100% declaration makes the metaboxes overlap the content in the editor. Simply removing those fixes the issues and has no ill effects.

    2. This is an issue on front-end as well as in the editor, but in this theme, the links are the same color as the text and also have underlines removed. This is bad for accessibility, so I’ve changed it on my site with a child theme, but this also carries over into the editor. The issue here is you can’t tell if you’ve actually inserted a link unless you click on the text where the link is.

    I’ve fixed both in a child theme for myself, but wanted to report the issues back upstream and wasn’t sure where else to do it. Didn’t see a GitHub repo or anything.

    Thanks for making a nice theme. Cheers!

Viewing 1 replies (of 1 total)
  • Theme Author Ben Sibley

    (@bensibley)

    Hi William,

    Thanks for posting these bugs here. I really appreciate it.

    Looks like I was moving too fast getting my themes ready for Gutenberg and left some pretty obvious errors in Shift! I’ve got an update ready and will be releasing it later today to address these issues.

Viewing 1 replies (of 1 total)
  • The topic ‘A couple of WP 5.0 issues’ is closed to new replies.