Support » Plugin: Wordfence Security » A couple of issues

  • Resolved chevymanusa

    (@chevymanusa)


    Hello there,
    First off thanks for the awesome plugin and support.
    I have searched google, the wordpress forums and the wordfence site.
    However, I have been unable to figure out how to clear this error:

    “Wordfence can’t get the IP of clients and therefore can’t operate. We received IP: 0. X-Forwarded-For was: REMOTE_ADDR was:”

    This wordpress install is hosted on a box with IPv4 not v6.
    Things I have recently done to troubleshoot:
    Disable Plugin
    Remove Plugin
    Drop “wf…” entries in the SQL database
    Re-install and reactive the plugin.

    The second issue I have encountered is for the past few months the “Top 404s” area is blank only showing: “No site hits have been logged yet. Check back soon.” Maybe two months ago or so there were results shown but as of the past two months there have been none.

    Anyways, many thanks in advance!

    Keep up the good work!

    Regards,
    Chevyman

    http://wordpress.org/extend/plugins/wordfence/

Viewing 1 replies (of 1 total)
  • Plugin Author Wordfence

    (@mmaunder)

    Hi Chevyman,

    Are you using Linux or Windows to host?

    It looks like your PHP installation does not use the standard variables and headers to pass PHP applications IP addresses. You’ve probably had issues with other applications that require this information.

    If you can tell me which HTTP header the IP address is stored in I can help. If you post the full error I may also be able to help.

    If you generate a page-not-found error on your site (re the top 404’s issue) what do you see? A 404 error, or is your server configured to not generate 404 errors?

    Regards,

    Mark.

Viewing 1 replies (of 1 total)
  • The topic ‘A couple of issues’ is closed to new replies.