Support » Plugins and Hacks » [Resolved] A couple bugs…

[Resolved] A couple bugs…

  • I am getting a warning everywhere for this on my WP version.

    Warning: Parameter 1 to array_multisort() expected to be a reference, value given in \wp-content\plugins\custom-field-suite\core\classes\api.php on line 498

    Adding an @ to that is dodgy, but seemed to fix it, without breaking anything.

    The other one that I am seeing is with the WYSIWYG, it displays ‘wrong’ until I click the resize icon once then it corrects itself. Can’t really figure that one out atm.

    Other than that its a great plugin. Simple and effective.

    The form validation also does not seem to work, if I set a field required its ignored.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Matt Gibbs



    1. We’re aware of that PHP warning. It’s been patched on GitHub and will be released along with the next version (1.8.5).

    2. Could you attach a screenshot of the Wysiwyg issue? It’s appearing fine on my local machine. It may be a compatibility issue with another plugin.

    3. I’ll test the field validation.

    In the meantime, could you browse to Field Groups > Tools and show me your site’s debug information?


    WordPress 3.5.1
    PHP 5.3.1
    Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1
    Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:21.0) Gecko/20130128 Firefox/21.0

    — Active Plugins —
    Contact Form 7 3.3.3
    Contact Form 7 Honeypot 1.1
    Custom Field Suite
    Login Logo 0.7
    WordPress SEO

    I realise I am using latest Nightly of Firefox but these happen in all of my browsers, including Chrome.


    I should also add that I commented out the Add Media for the wysiwyg – so don’t worry about that being missing, it also has nothing to do with the display issue. I didn’t want people getting confused between media field above and the wysiwyg.

    Plugin Author Matt Gibbs


    Oh, I see that the wysiwyg is within a loop field. Yes, it seems like TinyMCE has a hard time figuring out the proper height when it’s within a hidden container. Thanks for reporting, I’ll add it to the queue.


    Plugin Author Matt Gibbs


    Regarding validation, currently only top-level fields are supported. Support for fields within loops will likely get added in 1.9.x.

    Plugin Author Matt Gibbs


    FYI – this is a known core / TinyMCE bug: http://core.trac.wordpress.org/ticket/22168

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] A couple bugs…’ is closed to new replies.