Support » Plugin: Contact Form 7 » [_url] returns invalid URL

  • Resolved Jan Weiss

    (@rumpel2116)


    Hi there,

    just got the 5.4 update, thanks for all the work!

    The [_url] field displays in the email
    https://www.website.com/contact-form-7/v1/contact-forms/{id-of-form}/feedback?_locale=user instead of https://ww.website.com/site-with-form

    No additional plugins installed to mess with it.
    Only since 5.4 on my site.

    Thanks for looking into this!

    • This topic was modified 9 months ago by Jan Weiss.
    • This topic was modified 9 months ago by Jan Weiss.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Where can we see the website in question?

    Thread Starter Jan Weiss

    (@rumpel2116)

    The form is on many pages, for example here: https://www.rancharbeit.de/ranch-travel-australien.html

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    Thread Starter Jan Weiss

    (@rumpel2116)

    Hi,
    there are several plugins installed. But I deactivated all of them and turned them on one by one again and found the the one causing the issue: WP Rocket.

    Only happens if not logged in. If I’m logged in, the URL is correct. Therefore I didn’t find it last time I went with the troubleshoot-option of WP, deactivating all plugins.
    When not logged in, there are some errors in the console.

    It’s the option ‘Defer all JS’ of WP Rocket. I couldn’t figure out which files to exclude yet though to get it back running completely.

    I excluded wp-content/plugins/contact-form-7/(.*) from defer, then the URL is correct again, there are some more issues in the console though and the success-message is empty after filling the form.

    To make things easier with debugging, I duplicated the box here: https://bzy5fc.myraidbox.de/, form here: https://bzy5fc.myraidbox.de/farmstay/farmstay-in-den-usa.html with .htaccess protection to keep Google and similar out. Login with rb, cf7cf7. Cache and JS-minification deactivated for testing (same console results).

    Do you know why defer won’t work? Any ideas on the now upcoming errors?

    Cheers,
    Jan

    Thread Starter Jan Weiss

    (@rumpel2116)

    WP Rocket is thinking about solutions here, seems to be their issue: https://github.com/wp-media/wp-rocket/issues/3625

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[_url] returns invalid URL’ is closed to new replies.