Support » Plugin: Events Manager » #_EVENTEXCERPT{X,…} Doesn’t appear to be working

  • I am using #_EVENTEXCERPT {0, } because I want to leave the line blank if there is no excerpt rather than displaying the full description. This was working, but now, if there is no excerpt defined, the full description is displayed. It works with a non-zero number. Is it possible to fix this please?… I assume it must have been broken by a recent update.

    Alternatively, could you provide some code to create a conditional placeholder for excerpts.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • I can confirm the same problem. I had to revert to version 5.6.6.1 to restore our custom formatting on a list of events.

    Plugin Support angelo_nwl

    (@angelo_nwl)

    not sure if this is a bug since right now EM is using wp_trim_words and by default it will be set to 55

    however do you have sample screenshot of the previous and current result for us to see?

    I don’t have screenshots… The problem has occurred since #_EVENTEXCERPTCUT was introduced. The code seems to be a bit random! $trim is set but not used & the new test for excerpt_length being set doesn’t work for zero.

    I have changed it slightly… – passed $trim to output_excerpt & amended the test in output_excerpt for excerpt_length being set from ‘!empty’ to ‘is_numeric’. This seems to work for my case.

    It would be useful if this could be incorporated into the plugin code as my changes will get overwritten if the plugin is updated in the meantime.

    Thanks

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    Sorry, there’s no conditional placeholder for excerpts at the moment. It may be that you can use something like this:

    https://codex.wordpress.org/Function_Reference/has_excerpt

    This has been marked as resolved but it isn’t. #_EVENTEXCERPT is not functioning as it was previously – before #_EVENTEXCERPTCUT was introduced. I am unable to update to the latest version because I have had to ‘fix’ the code so the website displays as it should.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    It seems to me this change is the Dev team correcting something that didn’t make any sense. Setting the excerpt length to zero should make the excerpt length zero characters, which would defeat the object of including the placeholder.

    Because of that, it seems to me you’ve been making use of a bug that’s now been squashed 🙂

    The best option is probably to create a custom conditional placeholder (see link in my previous reply), or to create your own version of the placeholder by using this code as a start:

    https://pastebin.com/w2j1zebJ

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘#_EVENTEXCERPT{X,…} Doesn’t appear to be working’ is closed to new replies.