WordPress.org

Support

Support » Plugins and Hacks » [Resolved] #_ADDBOOKINGFORM not working

[Resolved] #_ADDBOOKINGFORM not working

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Franky

    @liedekef

    The POST-action in my case is just “#eme-rsvp-message”, meaning to use the same page. The POST-action you have is not correct … it’s even hardcoded to be that, so it should be the same for you.
    Can it be that something is rewriting stuff?

    It’s the encoding isn’t it… HTML5? Something is changing the # into UTC… I’ll investigate, but thank you for pointing me in this direction

    I have changed the Time Settings in WordPress… from UTC to London and now my # is converted to ‘Europe/Londonme-rsvp-message’

    So – my problem is identified… their is a conflict between Events Made Easy and the time settings in WordPress…

    This leads to the question of how to resolve… any ideas would be welcome.

    So a bit more…

    In my example (see link above) I have a date for each ‘event’ and this followed the format d/m/y… but I had also included the Timezone identifier… example my date read 12 Nov 2013 (UTC).

    The PHP Timezone identifier is ‘e’ and following the EME system I used #e in the ‘Default single event format’ settings…

    The result was that EME spotted the #e and converted all instances of it found on the page. Including in the Action Field of the form.

    I have now removed all instances of PHP time format characters from the page.

    The form now has the right Action – but unfortunately it still does not submit a booking to the database.

    Could it be to do with the Meta Charset?

    Plugin Author Franky

    @liedekef

    Thanks for letting me know about the #e conflict, I’ll need to solve that …
    For the post action: it now indeed has the correct action, but nothing seems to be happening. With this I mean: normally if you don’t fill out all required fields, you’ll see an error. In your case, I don’t. It seems as if the POST action is ignored and the page is just reloaded …

    Hi Franky, thank you for your help so far – still struggling… At the moment the form does not seem to validate. I have deactivate ALL plugins and the form continues not to validate.

    I remain a bit stumped… if anyone else has had this problem please can they let me know and if there is a solution.

    Plugin Author Franky

    @liedekef

    Have you checked your webserver logfiles? Maybe some apache module (e.g. mod_security) is blocking you?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] #_ADDBOOKINGFORM not working’ is closed to new replies.