Support » Alpha/Beta/RC » 90% of comments always held in moderation (random)

  • I’m having an issue with my comments. The discussion settings allow comments and are set right (no moderation) however wordpress moderates about 90% of my comments. 10% of them get through unmoderated, and there doesn’t seem to be any pattern to those 10% on why they get through. Has anyone else experienced any similar issues? Is there anything I can do for the comments to patch through without being held in the moderation queue?

    Theme: Stardust

    Active plugs:

    Akismet 2.1.6
    FeedBurner FeedSmith 2.3.1
    GeneralStats 0.72
    Related Posts 0.1
    Subscribe To Comments 2.1.2
    Visitor Counter Widget 1.1
    WP-DBManager 2.40
    WP-PostViews 1.31
    WP-PostViews Widget 1.31
    WP-Print 2.31
    WP-RelativeDate 1.31
    Yahoo/MSN Style Smileys 4.5

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What number of URLs do you have listed in Comment Moderation?

    Also, do you have any IPs or emails listed in that section?

    Issue solved .. if I’m not mistaking, theres a bug in the settings department 🙂

    That box with “hold a message for moderation if it contains X or more links” had a 1 in it (which always worked perfectly for WP 2.3 – holding in the moderation queue posts with 1 hyperlink in their message body). Setting it to 0 makes all the comments appear instantly.

    My guess is that right now, when the script checks for hyperlinks in the message body it also check for hyperlinks in the poster’s URL field (and well, as far as I know it shouldn’t 🙂 ). I’d check for this but I’ve no idea how to do it. Perhaps you could ask a dev to check the code syntax?

    Best,
    Andy

    Sorry for the double post … I’m on my laptop … 🙂

    @Ipsten: just answered it above. But that always worked with 2.3

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Huh, that is odd! I have it set to 4, and everything’s okay.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Huh. That doesn’t make any sense. The comment_max_links only applies itself to the comment_text, not to the URL field as well.

    Here’s the regular expression that it’s using:
    "|(href\t*?=\t*?['\"]?)?(https?:)?//|i"

    @otto: well .. then why didnt it work when it was set to 1? the comment_text was always clear of URL’s … the only URL’s were in the URL field!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Did their posts have the text “//” in them? That could possibly match that regular expression…

    I agree that setting it to zero making it work is indicative of that being the issue, I’m just trying to see how it could actually occur.

    No, just in the URL field. I also got over a hundred comments before the first day with 2.7 ended so there weren’t really “isolated” incidents.

    What I don’t understand is .. why did SOME of the comments get through without going through the moderation queue? They were plain comments just like the others (and some of them had the URL field filled too).

    Update:

    I tried to leave that box at “2” and see what happens with the comments.

    Next comment that was posted got stuck in the moderation queue even though it had NO hyperlink whatsoever in it (not even the URL field – which was blank) and no “\”‘s either.

    Something’s definitely wrong somewhere … can it be because of the theme or something?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You could test it with the default theme (make a ‘user’ ID for yourself to test with).

    My other suggestions would be ‘Turn off all plugins and test’ and ‘Reupload 2.7 and test’

    I also have the same problem with comments in moderation. I have tested in several themes and without plugins. 🙁

    I am having a problem with this too, on only one blog. I have the settings the same as all my other blogs. The only pattern I think I see is that it is holding comments with smilies for moderation possibly.

    YES!!! That’s it!!! I’ve been having a similar problem that’s been driving me crazy. Even though I have moderation off, *one* user’s comments always gets moderated. It’s because he’s the only one that uses smileys! I just did some testing that that did it. Comments with smileys are moderated!

    Now, is this a bug or feature? Is there a fix or workaround?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It’s a bug, it’s been reported on.

    Great! Also, I did some more testing, and FWIW smilies don’t *always* trigger the moderation like I originally said, but there’s definitely a relation.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘90% of comments always held in moderation (random)’ is closed to new replies.