Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » 8.7 update caused site crash

  • Resolved Sally DeFord

    (@sallydeford)


    In updating to 8.7 my site crashed hard… as in, I couldn’t even get into the back end. Fortunately, WordPress has “recovery mode.”

    I had updated four other plugins at the same time. The WordPress technical issue e-mail identified Jetpack as the culprit. I restored all five plugins to previous editions (using Updraft)… all good. Then updated the four others (not including Jetpack this time) and all still good.

    8.6.1 works fine for now, but… I guess I’ll skip 8.7 and wait for the next one?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Fotis

    (@fstat)

    Hi there,

    We don’t have any reports with the update process of the latest version. I just updated a couple of my sites to version 8.7 without any issues. Can you try the update once more and let me know how it goes?

    update to 8.7 is preventing login on all my sites.
    [10-Jul-2020 15:37:21 UTC] PHP Fatal error: Uncaught Error: Class ‘IXR_Client’ not found in /home/lamp/wordpress/plugins/jetpack/vendor/automattic/jetpack-connection/legacy/class-jetpack-ixr-client.php:17
    Stack trace:
    #0 /home/lamp/wordpress/plugins/jetpack/vendor/autoload_packages.php(168): require_once()
    #1 [internal function]: Automattic\Jetpack\Autoloader\autoloader(‘Jetpack_IXR_Cli…’)
    #2 [internal function]: spl_autoload_call(‘Jetpack_IXR_Cli…’)
    #3 /home/lamp/wordpress/plugins/jetpack/vendor/automattic/jetpack-sync/src/class-actions.php(322): class_exists(‘\\Jetpack_IXR_Cl…’)
    #4 /home/lamp/wordpress/core/wp5.4/wp-includes/class-wp-hook.php(287): Automattic\Jetpack\Sync\Actions::send_data(Array, ‘deflate-json-ar…’, 1594395441.4734, ‘sync’, 0.012815952301025, 0.028102874755859, 1
    034, ‘5f088b3169a0a’)
    #5 /home/lamp/wordpress/core/wp5.4/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #6 /home/lamp/wordpress/plugins/jetpack/vendor/automattic/jetpack-sync/src/class-sender.php(481): apply_filters(‘jetpack_sync_se…’, Array, ‘de in /home/lamp/wordpress/plugins/jetpack/vendor/automattic/jetp
    ack-connection/legacy/class-jetpack-ixr-client.php on line 17

    I’ve tried 8.7 and 8.7.0.1 both have this problem.
    Downgraded to 8.6.1 and everything is OK again.
    N.B. our plugin directory is outside the wordpress tree and files are owned by root, we use a python script and SVN to update plugins twice daily.

    My bad, forgot to reload apache after downloading 8.7.0.1, problem solved with that. However it is not the stable tag in readme.txt so my auto update will backtrack to 8.7 in 7 hours.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    Thanks for the extra details. We’ll be looking into this, and you can follow our progress on this here:
    https://github.com/Automattic/jetpack/issues/16466

    However it is not the stable tag in readme.txt so my auto update will backtrack to 8.7 in 7 hours.

    We’re planning on releasing Jetpack 8.7.1 soon, so that should solve that problem.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    It appears that restarting OPCache clears the issue for now. There will also be some changes in the upcoming version of WordPress, scheduled to be released next month, that will aim to solve those issues.

    Let us know if this keeps happening after that release!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘8.7 update caused site crash’ is closed to new replies.