Support » Fixing WordPress » 7/8 nightly– can’t edit posts!

  • With the 7/8 nightly build I can’t seem to edit posts. It seems like things are working (I can choose edit, make changes, and save) but the saves are not being committed to the database! There are no errors reported either…

Viewing 7 replies - 1 through 7 (of 7 total)
  • Link please.
    And have you installed in 2 directories ?
    And if you have, and you totally certain you are editing the correct files ? (This error has occurred twice here recently)

    Link to ?? I have only installed in one directory and have only one WP blog (http://www.cosmopoetica.com/). I upgraded in an attempt to get pings and trackbacks (outward) working. They still do not.

    Here is the dump from editpost (I’m going to try to log the query and see what is not happening):
    array(28) {
    ["user_ID"]=>
    string(1) "1"
    ["action"]=>
    string(8) "editpost"
    ["post_ID"]=>
    string(2) "26"
    ["post_title"]=>
    string(15) "Excuse the Dust"
    ["post_category"]=>
    array(1) {
    [0]=>
    string(1) "8"
    }
    ["post_status"]=>
    string(7) "publish"
    ["comment_status"]=>
    string(4) "open"
    ["ping_status"]=>
    string(4) "open"
    ["post_name"]=>
    string(15) "excuse-the-dust"
    ["post_password"]=>
    string(0) ""
    ["excerpt"]=>
    string(0) ""
    ["content"]=>
    string(408) "Welcome... I\'m still moving in, but I hope to have things under control by the end of the weekend!
    If you are an RSS user (and you should be!), you can subscribe to feeds for Cosmopoetica Entries and Comments."
    ["post_latf"]=>
    string(7) "64.8351"
    ["post_lonf"]=>
    string(8) "-147.645"
    ["post_pingback"]=>
    string(1) "1"
    ["prev_status"]=>
    string(5) "draft"
    ["trackback_url"]=>
    string(0) ""
    ["submit"]=>
    string(4) "Save"
    ["referredby"]=>
    string(50) "http://www.cosmopoetica.com/blog/wp-admin/edit.php"
    ["edit_date"]=>
    string(1) "1"
    ["jj"]=>
    string(2) "10"
    ["mm"]=>
    string(1) "7"
    ["aa"]=>
    string(4) "2004"
    ["hh"]=>
    string(2) "07"
    ["mn"]=>
    string(2) "22"
    ["ss"]=>
    string(2) "32"
    ["metakeyinput"]=>
    string(0) ""
    ["metavalue"]=>
    string(0) ""
    }

    I figured out where the problem is. If I comment out the GeoURL info in the post.php and set it manually, everything works fine! It must have to do with pinging geourl?
    Here is the change I made
    /* if(get_settings('use_geo_positions')) {
    $latf = floatval($_POST["post_latf"]);
    $lonf = floatval($_POST["post_lonf"]);
    $latlonaddition = "";
    if( ($latf != null) && ($latf <= 90 ) && ($latf$
    pingGeoUrl($post_ID);
    $latlonaddition = " post_lat=".$latf.", post_lo$
    } else {
    $latlonaddition = " post_lat=null, post_lon=nul$
    }
    } else {
    $latlonaddition = '';
    }
    */
    $latlonaddition = '';

    I guess the shorter answer would be to turn off pinging GeoURL for now 🙂

    It’s possible it could be timing out (for some reason).

    Quite likely, since none of my pingback and trackbacks don’t work and I am suspecting that pingomatic pings aren’t going out either, but I can’t confirm.It would be NICE if WP did some logging of these kinds of things!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘7/8 nightly– can’t edit posts!’ is closed to new replies.