• Resolved SlouchyFlower

    (@slouchyflower)


    According to the PHP Compatibility Tester, Genesis Layout Extras has 3 warnings with PHP 7.2. Any chance you can fix them? TIA!

    FILE: /wp-content/plugins/genesis-layout-extras/includes/gle-layout-extras.php
    ———————————————————————————————————————————————————————–
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ———————————————————————————————————————————————————————–
    185 | WARNING | Function name “__gle_return_sidebars_below_content” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    199 | WARNING | Function name “__gle_return_content_sidebaralt” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    213 | WARNING | Function name “__gle_return_sidebaralt_content” is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    ———————————————————————————————————————————————————————–

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author David Decker

    (@daveshine)

    @slouchyflower
    Hi and thanks for your feedback!
    Sorry for the delay.

    Thanks for bringing this to my attention. Am I right in assuming you were using this plugin for scanning/ testing? https://wordpress.org/plugins/php-compatibility-checker/
    If you did use another tool please tell which one, that would really help me.

    I tested on my own and can say this so far:
    1) the plugin works totally fine under PHP 5.6 up to 7.3 without errors — tested on live sites
    2) these functions are in the plugin since 2013 already, I cannot just take them out – there might be hundreds, or even some thousand users relying on them
    3) WordPress Core is using very similar functions since year 2010 (WP 3.0) for example __return_true() and similar. There are no special handlers or anything for PHP 7.2 or higher in Core.
    4) These results you posted are currently “warnings”, no errors. These are also no “methods” technically, but procedural functions as my plugin is currently not OOP based.

    With all that said, I always try for highest compat, and also test on new PHP versions also. For the meantime you can ignore those warnings and use the plugin as before.

    Thanks again, Dave 🙂

    SlouchyFlower

    (@slouchyflower)

    Yep, that’s the plugin I used. If it’s backward compatibility, that’s cool with me. Thanks for checking and answering!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘7.2 Compatibility warnings’ is closed to new replies.