WordPress.org

Support

Support » Plugins and Hacks » [Resolved] 6.3.7 breaks call_user_func_array

[Resolved] 6.3.7 breaks call_user_func_array

  • After updating eShop from 6.3.5 to 6.3.7 on WP v3.5, I began receiving errors in the dashboard as follows:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘eshop_orderhandle_process’ was given in /*path-to-wp-install*/wp-includes/plugin.php on line 487.

    Rolling back to 6.3.5, the warning disappears. Only other plugins activated are Akismet and Google Analytics.

    Site is http://beccayoderart.com. Errors won’t appear because I’m back on eShop v6.3.5, and they’re only showing to logged-in admin users.

    Others are apparently having the same issue:
    http://quirm.net/forum/topic.php?id=18247

    http://wordpress.org/extend/plugins/eshop/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author elfin

    @elfin

    then why didn’t you follow up on the Quirm? or are you not using multisite?

    I have already answered saying I will look at this on the weekend.

    I’m not a member of Quirm.net, and I’m not using multi-site. Thanks for the attention to the issue. We’re still operational on 6.3.5.

    esmi

    @esmi

    Forum Moderator

    If you are seeing this error, please indicate on what page(s) it occurs. Otherwise, we may not be able to replicate the problem.

    And see http://quirm.net/forum/topic.php?id=18247

    Errors are appearing on these pages:

    wp-admin/upload.php
    wp-admin/edit.php
    wp-admin/edit.php?post_type=page

    esmi

    @esmi

    Forum Moderator

    Can you replicate the problem using the default theme with all other plugins deactivated? At the present time, we cannot replicate this on any of those pages.

    I recreated the problem on a test site using same content and imported MySQL db, same plugins, same theme. Then I disabled all plugins other than eShop, tried the default themes (twenty-twelve, twenty-eleven, twenty-ten) one by one, and the error persists…

    How can I be helpful?

    esmi

    @esmi

    Forum Moderator

    No – try a completely fresh single install. No imported content, no imported database. And definitely no multisite.
    So far this issue can only be replicated in multisite installs.

    Plugin Author elfin

    @elfin

    6.3.8 released to fix this for multisite installs. In theory if you had this issue it should now be resolved.

    Wow, quick work! I’m not running multisite, but I can verify that 6.3.8 fixed the issue on my two test sites and the live site that were *all* showing the same error. Thanks for your fast response.

    esmi

    @esmi

    Forum Moderator

    You’re welcome. 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] 6.3.7 breaks call_user_func_array’ is closed to new replies.