Support » Alpha/Beta/RC » 6.0-RC4: layout for row block is always align-items: center

Viewing 5 replies - 1 through 5 (of 5 total)
  • Justin Tadlock

    (@greenshady)

    The Row variation does not support vertical alignment. If you select a vertical orientation, it will switch to the Stack variation. Both are, technically, just variations on the Group block.

    So, if you select vertical orientation, you should see something like this for the block code:

    
    <!-- wp:group {"layout":{"type":"flex","flexWrap":"nowrap","orientation":"vertical"}} -->
    <div class="wp-block-group"><!-- wp:paragraph -->
    <p>hello</p>
    <!-- /wp:paragraph -->
    
    <!-- wp:paragraph -->
    <p>world</p>
    <!-- /wp:paragraph --></div>
    <!-- /wp:group -->
    

    In the editor and on the front end, the nested blocks should be “stacked” one after another.

    Can you a screenshot of what you’re seeing?

    Thread Starter douglasjohnson

    (@douglasjohnson)

    I’m refering to "verticalAlignment":"top" rather than "orientation":"vertical"

    
    <!-- wp:group {"layout":{"type":"flex","flexWrap":"nowrap","verticalAlignment":"top"}} -->
    <div class="wp-block-group"><!-- wp:paragraph -->
    <p>Row Item One Row Item One Row Item One Row Item One Row Item One Row Item One</p>
    <!-- /wp:paragraph -->
    
    <!-- wp:image {"id":50,"sizeSlug":"full","linkDestination":"none"} -->
    <figure class="wp-block-image size-full"><img src="http://dev.local/wp-content/uploads/2019/01/beanie-with-logo-1.jpg" alt="" class="wp-image-50"/></figure>
    <!-- /wp:image --></div>
    <!-- /wp:group -->
    

    I am not able to include a screenshot in this comment.

    Thread Starter douglasjohnson

    (@douglasjohnson)

    Here are the screenshots

    In the editor, I can select “Align top” and it is reflected in the content.
    https://drive.google.com/file/d/1NrBXKAWewlmrPb-zt-A1qYAtYnMcTVKT/view

    But on the front-end, align-items:center is still applied.
    https://drive.google.com/file/d/194swMnus5-xOnMkEBmjFW0E2rZ3Xbj8i/view

    Justin Tadlock

    (@greenshady)

    Thanks for the additional feedback. I can confirm that this is indeed an issue. I’ll look to see if it has been reported, and if not, create a new ticket upstream to see if we can get it fixed in WordPress.

    Justin Tadlock

    (@greenshady)

    I have reported this upstream in the Gutenberg repository: https://github.com/WordPress/gutenberg/issues/41324

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.