Support » Plugin: Link Library » 6.0 and Link RSS Feed

  • Resolved Andyt8

    (@andyt8)


    Hello,

    I found a problem with RSS Feed in Link Librarys 6.x.

    It look likes the old url for RSS Feeds work, but they show all categories. I have four Link Librarys and each of them shows always all links.

    Additional I tried to use https://blackseals.net/feed/linklibraryfeed, but that have a wrong title (title is from first link library). Don’t know if that should normally work.

    best regards, Andyt

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    I checked and the RSS generation has been updated, just like the rest of Link Library.

    The correct URL is definitely https://blackseals.net/feed/linklibraryfeed. If you have multiple libraries, then you would add the settings ID at the end of the URL to show each one in their own feed: https://blackseals.net/feed/linklibraryfeed?settingsset=2

    To see that the links are coming from the new version, have you tried something like changing the title of a link and seeing if it updates in the RSS feed? If you have tried this, then perhaps you are just having an issue with caching. By default, WordPress caches RSS Feeds so it does not need to re-generate them all the time. You can add the following code to your theme functions.php file to disable caching:

    function do_not_cache_feeds(&$feed) {
       $feed->enable_cache(false);
     }
    
     add_action( 'wp_feed_options', 'do_not_cache_feeds' );

    Then see if the feed shows updated titles.

    Hello,

    Thank you for your answer. The problem isn’t any updated link title. The problem is a wrong link list. It shows according to the link library wrong links.

    For example https://blackseals.net/feed/linklibraryfeed?settingsset=2 shows at the moment as second Space-Engineers.de, which is wrong in that link library.
    According to https://blackseals.net/blogroll/roadster/ there should be many other links, but not that one.

    According to https://blackseals.net/feed/linklibraryfeed: it shows me a wrong RSS-Feed title. It use “BlackSeals.net » Space Engineers Links” which is the same from https://blackseals.net/feed/linklibraryfeed?settingsset=1. I don’t know how to change the RSS-Feed-title for the main Link-RSS-Feed. I would prefer “BlackSeals.net » Links”. There are four link library which have there own RSS-Feed-title.

    best regards, Andyt

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    1) Are you specifying the categories to be displayed using the included categories field, or the excluded categories? Is the link that is appearing in a category that should not appear?

    2) https://blackseals.net/feed/linklibraryfeed and https://blackseals.net/feed/linklibraryfeed?settingsset=1 are the same. They both serve up links from Library Configuration 1. If you have four different libraries, then you can access each of them with settingsset=1 through to settingsset=4. When you don’t specify a number, it serves up number 1, as a lot of users only have a single library.

    1) Yes, I did that. It worked with 5.x. If I use Shortcode to include for example Link Library 2, then I see only links from Link Library 2. The RSS-Feed for Link LIbrary 2 shows all links.

    I use “Categories to be displayed” and have no exclusions.

    2) Ok, I unterstand. I thought https://blackseals.net/feed/linklibraryfeed shows Links from all Link Libraries. I didn’t know that url before I upgraded to 6.x. I used in the past only settingsset=1 to settingsset=4.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    1) I just pushed an update to address the issue with links not respecting the list of categories to be displayed. 6.0.24. Please update and confirm that this resolves the issue.

    Hello,

    Thank you. The problem is fixed with that update.

    kindly regards, Andyt

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘6.0 and Link RSS Feed’ is closed to new replies.