WordPress.org

Support

Support » Plugins and Hacks » 504 Error with nginx and php-fpm

504 Error with nginx and php-fpm

  • I noticed a performance issue starting this sunday morning with a lot of 504 Error (running WP 3.5.1, plugin Version 0.6.3) on only two of my WordPress sites. The other ones were working perfectly.

    Increasing time-out for nginx and php-fpm did not much and the pages were just very very slow to show up. After extensive tests on my server I remembered the last things I have done on these two only sites that caused troubles was to update NewStatPress.

    After desactivating NewStatPress in both sites everything went back to normal.

    To be sure of this I reactivated the plugin on one site and the performance problem showed up again immediatly.

    Everything worked fine previously to this update and my other sites on which I did not update the plugin work fine.

    I just think I should let you know.

    http://wordpress.org/extend/plugins/newstatpress/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author ice00

    @ice00

    hi,

    I’m investigating this issue

    thanks

    Hello,

    I reactivated the NewStatPress plugin today on one site and the site worked like before (did nothing else appart from reactivating). I upgraded (to Version 0.6.4) the other one and reactivated the plugin too. So far, so good.
    I still believe that NewStatPress is involved somehow with the previous performance issues but these might be tied up with my server/php configuration as well. I will watch any change and let you know.

    Please note that I really do find this plugin handy and usefull.
    Thank you vey much for your work.

    Hello, I saw the same situation when activating NewStatPress plugin.
    The responses are quite slow not only for authenticated users but also cached contents for anonymous users.
    But cpu, memory, MySQL have no so heavy reaction while waiting for response….

    After that I found that there are many failed records of netstat graph generated via Munin. So, I tried monitor netstat command and found some outgoing requsts to resolve host name from ip address are failed or timeout.
    I wonder this problem is due to a DNS problem…

    yed44, are you running your site behind a firewall?

    Hello Everybody,

    I experienced this same issue twice again in the last two weeks (Version 0.6.4)… I am using nginx/php-fpm/Fcgiwrap/naxsi/BIND/Jailkit/Fail2Ban and CSF.

    What puzzles me is that it only happen with one or two of my sites and only at certain period of time (like twice during the week-end). So I thought this was related to some other WP crons. Now I upgraded all sites to the last version of the NewStatPress plugin (Version 0.6.5) and desactivated two other ones (CCB and WP-DBManager).
    I will see what happen and let you know. Next time this shows up I will have a look at network stats/logs too.

    Plugin Author ice00

    @ice00

    On activating Newstatpress plugin there is the routine that tests the version and registers it inside newstapress.altervista.org database for the %instaled% function.

    However let me know your test, as DNS problem is a possible cause I’m looking for.

    The 504 happened consistently to me too when I update to 0.6.5 (not sure from which version, but it was a 2 months gap). I’m running nginx/php5-fpm/php5.4.16/wordpress3.5.2

    I then tried downgrading version by version and found that 0.6.1 works fine. Hope that helps

    Plugin Author ice00

    @ice00

    hi, use new 0.6.7 that is similar to 0.6.1

    Hello, I had to desactivate the plugin because of this issue. I will give a try to the 0.67 version and let you know. Thanks for you effort!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘504 Error with nginx and php-fpm’ is closed to new replies.