Support » Plugin: Gallery Custom Links » 503 server error happens

  • Resolved maitreart

    (@maitreart)


    Hi there,
    I’ve met this issue before but never could resolve it.

    Today, my client can not load any options in the WP admin area after activating your plugin. I can’t turn on debug mode, but the client asked her hosting provider for a PHP log.

    Hosting support told the plug-in takes too much time to proceed, so the server stopped interacting with it, and they could not help further since they have tried to raise the time limit to 300, and it is already maximum.

    What should I do? I can also provide full PHP logs.
    Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @maitreart,

    Do you have big pages? Gallery Custom Links needs to analyze the page before outputting it, normally that’s instant, but in some cases it might happen…

    I don’t mind seeing your PHP logs, but please try to pick the parts which are happening during the process of generating a page.

    Thread Starter maitreart

    (@maitreart)

    @tigroumeow Yes, we have big pages.
    We are authors of Themeforest, so we have extensive demos, a lot of customers use our themes with the demo and your plugin, and everything is fine. But several customers have problems with your plugin, and we need to find out why it happens because we use your plugin in every theme.

    Here is the main error:
    [Mon Jan 31 07:04:37.676192 2022] FastCGI: server "/home/clients/861ca6033e21973e5196e62ffb315128/.config/apache/taobe.consulting/.fpm/php5.external" stderr: PHP message: PHP Fatal error: Maximum execution time of 300 seconds exceeded in /home/clients/861ca6033e21973e5196e62ffb315128/web/wp-content/plugins/gallery-custom-links/classes/core.php on line 207

    What are we supposed to do? Is there a way to fix it?
    Thanks.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @maitreart,

    If I share an install with you, do you think you would be able to replicate the issue? However, I am a bit afraid that it is an issue with the librairies I am using to parse the HTML code.

    Also, please ask your customers with this issue to change the settings of the plugin. By default, the HtmlDomParser is used, but you can switch to DiDom. DiDom is much faster, but it fails to work on pages with badly formatted HTML. If your theme generates valid HTML, that will work, and DiDom has much less chance to timeout. You can also add a function call to force this setting automatically by default if that helps ๐Ÿ™‚

    Thread Starter maitreart

    (@maitreart)

    Hi @tigroumeow,
    Thanks for your answer!

    I think we couldn’t replicate the issue, because it happens with certain servers.

    Our HTML is perfect ๐Ÿ˜ฌ we check our themes through validator.w3.org.

    Can you provide this function, please? I can’t find it…

    Thanks again.

    Plugin Author Jordy Meow

    (@tigroumeow)

    It’s just in the settings, under Meow Apps, Custom Links, and pick DiDom ๐Ÿ™‚

    Thread Starter maitreart

    (@maitreart)

    @tigroumeow

    You can also add a function call to force this setting automatically by default if that helps

    I mean the function that we can add in our theme that will force the DiDom setting by default. Because if we activate your plugin it will again cause the error and remove ability to use WP admin area.
    Does it make sense?

    Thread Starter maitreart

    (@maitreart)

    @tigroumeow So finally, the website is working, but the issue was with OB Mode.
    I turned it off, and now everything is okay.

    The parsing engine didn’t affect the problem.
    Why did the OB mode cause the issue? What do you think?

    Thanks a lot!

    Plugin Author Jordy Meow

    (@tigroumeow)

    Indeed! That happens if another plugin starts buffering an output without checking if there are other plugins (or the theme) doing this. In my experience, Yoast SEO does this, and that causes many issues, but other than that, I don’t remember other plugins having this effect.

    Thread Starter maitreart

    (@maitreart)

    It’s bizarre. I turned off all plugins, activated the Twenty Twenty One theme, and had the same issue with the server.
    I don’t know why it happens. Maybe it server CPU issue.

    Anyway, I think your plugin is fine. Even with the Yoast SEO plugin, it works great on other servers.

    So I guess we can close this thread.
    Thanks again!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.