Support » Plugin: Thumbnail Cleaner » 503 Error everytime

  • Hello! Trying to use the plugin but it keeps giving me a 503 error. I even tried shortening the date span for cleanup, but to no avail. Anything I can do to get it to work?

    Thanks!

    Jessica Festa

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author thaikolja

    (@thaikolja)

    Hi Jessica,

    We should start solving this problem by having a look at the log files WordPress creates when something goes wrong. If you don’t know how to enable this feature, do this:

    1. Go to your WordPress directory (the directory where you find the folders wp-content and wp-includes).
    2. Open the file wp-config.php.
    3. Scroll down to the line where it says define('WP_DEBUG', false); and remove it.
    4. Add the following code to the next line:

    define("WP_DEBUG", true);
    define("WP_DEBUG_LOG", true);
    define("WP_DEBUG_DISPLAY", true);
    define("SCRIPT_DEBUG", true);
    @ini_set("display_errors", 1);

    Now, try reproducing the error. After that, check the following directories for the files “error.log” or “debug.log”.

    1. WordPress root directory
    2. wp-content
    3. wp-content/plugins
    4. wp-content/themes

    If you find any, please post them here.

    I have the same issue.
    I would expect the analysis process to run through Ajax… when there’s over 10GB of uoloads, it’s impossible that the script will ever run to completion, it will forever timeout like this.

    Apache Error
    (70007)The timeout specified has expired: AH01075: Error dispatching request to : (polling), referer: wp-admin/tools.php?page=thumbnail-cleaner

    Ajax IS necessary I’m afraid.
    Any plans to implement it?

    • This reply was modified 2 years, 5 months ago by  Duke.
    Plugin Author thaikolja

    (@thaikolja)

    Yeah, AJAX is one of the solutions. However, right now, I have not enough time to implement this. As soon as I can, I’ll update it. Please be patient.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘503 Error everytime’ is closed to new replies.