Support » Plugin: WP Performance Pack » 502 Bad Gateway error

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Bjoern

    (@greencp)

    Do you have access to the server logs? The cause might be the test for native gettext support. I’ll try to improve the error handling but to be sure the error logs would help.

    Plugin Author Bjoern

    (@greencp)

    Please try version 2.2.6. This should fix your problem if the cause was what I suspected it to be.

    Hi Bjroen,

    Thank you for the update. I have tested it and it still returns a 503.

    I checked my phpinfo() and saw that PHP is compiled with gettext support. I’m using https://localbyflywheel.com

    I’m researching even deeper to see where the 503 may be comming from. I’ll keep you posted!

    Jaime

    Plugin Author Bjoern

    (@greencp)

    I just downloaded local for windows version “5.2.5+2498” (seems to be a nice development environment btw) and made a quick test using a fresh WordPress. I get no errors. What OS are you using? And which PHP 7.2 version exactly (in my test local installed PHP 7.3.5)?

    Ok, it is in the is_native_gettext_available() check.

    I traced it back to there and when I “return 1;” early in the function, no 502.

    Then I debugged the function further and found that $native_gettext_test = $mo->translate( ‘native-gettext-test’ );
    was the trigger.

    These were also the notices / errors I found in logs:

    `
    [28-Feb-2020 09:30:14] WARNING: [pool www] child 6321 said into stderr: “ld: warning: option -s is obsolete and being ignored”
    [28-Feb-2020 10:00:01] WARNING: [pool www] child 6320 said into stderr: “sh: /usr/bin/dot: No such file or directory”
    [28-Feb-2020 10:06:01] WARNING: [pool www] child 6320 said into stderr: “close failed in file object destructor:”
    [28-Feb-2020 10:06:01] WARNING: [pool www] child 6320 said into stderr: “sys.excepthook is missing”
    [28-Feb-2020 10:06:01] WARNING: [pool www] child 6320 said into stderr: “lost sys.stderr”
    [28-Feb-2020 10:16:18] WARNING: [pool www] child 6321 said into stderr: “dyld: lazy symbol binding failed: Symbol not found: _iconv_open”
    [28-Feb-2020 10:16:18] WARNING: [pool www] child 6321 said into stderr: ”  Referenced from: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/php-7.3.5+3/bin/darwin/sbin/../shared-dylibs/libintl.8.dylib”
    [28-Feb-2020 10:16:18] WARNING: [pool www] child 6321 said into stderr: ”  Expected in: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/php-7.3.5+3/bin/darwin/sbin/../shared-dylibs/libiconv.2.dylib”

    `

    I don’t get this error on my external webserver so I think it has to do with Local by Flywheel not having loaded al the stuff “WPPP_Native_Gettext” needs… I guess.

    I’m researching some more, by checking out a different development enviroment.

    Jaime!

    Ah you just replied:

    OSX: 18.6.0 Darwin Kernel Version
    PHP Version 7.3.5

    Configure Command ‘./configure’ ‘–enable-static=’ ‘–enable-fpm’ ‘–enable-zip’ ‘–enable-soap’ ‘–enable-opcache’ ‘–enable-mbregex’ ‘–enable-mbstring’ ‘–enable-pdo’ ‘–enable-ftp’ ‘–enable-sockets’ ‘–enable-exif’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–enable-shmop’ ‘–enable-pcntl’ ‘–with-pdo-mysql’ ‘–with-openssl=/usr/local/opt/openssl@1.1’ ‘–with-curl=/usr/local/opt/curl’ ‘–with-zlib-dir=/usr/local/opt/zlib’ ‘–with-gettext=/usr/local/opt/gettext’ ‘–with-xmlrpc’ ‘–with-mysqli’ ‘–with-pcre-regex’ ‘–with-jpeg-dir’ ‘–with-png-dir’ ‘–with-freetype-dir’ ‘–with-gd’ ‘–with-bz2=/usr/local/opt/bzip2’ ‘–with-xsl’ ‘–with-iconv=/usr/local/opt/libiconv’ ‘–without-pear’ ‘–without-sqlite3’ ‘–without-pdo-sqlite’ ‘–prefix=/Users/runner/runners/2.159.2/work/_temp/local-lightning-php/php-7.3.5/build’

    I will disable all my plugins and check if they maybe interfere. (Tomorrow)

    Thank you for your time and will report back.

    Ciao!

    Plugin Author Bjoern

    (@greencp)

    Did you ever manage to find a cause for your problem? I haven’t tested with Local anymore since then.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘502 Bad Gateway error’ is closed to new replies.