WordPress.org

Forums

Quick Cache (Speed Without Compromise)
502 Bad Gateway (2 posts)

  1. nando99
    Member
    Posted 9 months ago #

    Running the latest version of WP on nginx.

    When the plugin is enabled, I get a 502 Bad Gateway error when I edit an already published post.

    After I disabled it and re-enable it, it works for while and then it breaks again.

    Any ideas?

    https://wordpress.org/plugins/quick-cache/

  2. Raam Dev
    Member
    Plugin Author

    Posted 9 months ago #

    I haven't seen this issue before and I haven't been able to reproduce this error at all when testing Quick Cache locally with Nginx.

    You might want to try contacting your web host to see if they can offer any insight. Searching Google for "WordPress Nginx 502 Bad Gateway" comes up with a lot of reports of others having a similar issue and in all cases contacting the web host seems to be the best course of action.

    If you have access to the server logs, those might provide some clues as to what's happening when you attempt to edit an already published post. It could be that when Quick Cache runs its auto-purge routines (to clear any cache files associated with the post you're editing), something funky is happening on the server to throw the 502 error, related to your specific server configuration.

Reply

You must log in to post.

About this Plugin

  • Quick Cache (Speed Without Compromise)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic