Support » Plugin: MimeTypes Link Icons » 500 Server Error on Settings, icons not displaying

  • Resolved sndu

    (@sndu)


    Hi,

    I just started using your plugin a couple weeks ago and it’s fantastic! Thanks for sharing your hard work with the WP community.

    I’ve encountered 2 problems since the 3.0 upgrade:

    (1) I get a 500 server error when I click the ‘Settings’ link for MimeTypes Link Icons on the plugins page.

    (2) Using Related Posts plugin makes all the mime type icons disappear. When I disable Related Posts, the icons reappear by my file links. Disabling Related Posts does not affect the 500 error on the Settings page though. (It’s still there.)

    I downgraded to the pre-3.0 version and both of these problems went away (no conflict with Related Posts and no server error for Settings, though I realize the Settings page is set up differently in v2)

    I didn’t see anything related to mimetypes-link-icons in the debug.log, but I might not know what I’m looking for.

    How would you recommend I try to diagnose the problem?
    Thanks!

    http://wordpress.org/extend/plugins/mimetypes-link-icons/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor jrf

    (@jrf)

    Hi sndu,

    Thank you for your kind words and for reporting this.

    Concerning point 1:
    A 500 error is a server error. V3 of the plugin uses the WP native settings API, so do you get this error when trying to save other settings of other plugins using the settings API as well or do you only get this error with this plugin ?
    Most commonly, a 500 error is caused by an error in .htaccess. Do you run any plugins which affect the .htaccess file ?
    To diagnose this one, have a look at the server access log / error log – you can normally access those via your webhosting control panel and sometimes via FTP. These logs should give you some clue as to which url is causing the 500 error and what the actual error message is.

    Concerning point 2, I need to know more info, such as:
    * are you using async mode or non-async mode ?
    * are you excluding any classes ?
    * have you got a link to a webpage where I can see the problem ?
    * you mention a debug.log – what do you log there and which settings are you using for the logging ?

    Pro-tip: if you open up the settings page with WP_DEBUG set to true, you will see a complete list of the current settings for this plugin at the bottom of the MTLI settings page.

    Hope this helps and please let me know what you find.

    Smile,
    Juliette

    Hi Juliette,

    Thanks so much for your reply! For point 1 – I checked 5 other plugins with Settings pages, and I didn’t have trouble loading or saving their Settings page. And sorry that I was unclear; I get the server error when trying to load the Settings page, not when trying to save it.

    For point 2, I’m not sure what settings I’m using since I can’t view the Settings page. I’m assuming it’s whatever the default is after the upgrade. Or does it migrate my settings from the 2.0 branch? If so, I was using the non-async mode, not excluding anything.

    Sorry I haven’t had time to tinker yet, but I’ll find time to try the upgrade again soon and get back to you in a couple days.

    Thanks!

    Plugin Contributor jrf

    (@jrf)

    Hiya,

    Just checking: you said you get the server error when trying to load the Settings page when you click on the Settings link on the plugins page.
    Do you also get the server error when you click on link in the menu ? I.e. the menu on the left of the admin page -> Settings -> MimeType Icons ?

    I kind of expect you don’t and I’ve made some fixes to adjust the links displayed on the plugins page. If you can confirm that the link in the menu works, I will submit the fixes for the next version.

    Once you get the page loaded (via the menu), we’ll move on to point 2 😉

    Smile,
    Juliette

    Oh, you’re right! I don’t get the server error if I click the Admin Sidebar->Settings->MimeType Icons — only when I click the link on the Plugins page.

    From there I could check my settings and enable async mode. Now the plugin works at the same time as Related Posts.

    Thanks for the fantastic help!

    Plugin Contributor jrf

    (@jrf)

    Glad to hear that solved it and you’re very welcome. Could you mark this topic as resolved ? Thanks!

    I’ve submitted the fixed settings links for the plugin page to be included in the next version. If you are eager to get the fix in, you can always download the latest version from GitHub. Or just copy over the changes from my pull request – which should probably be accepted within a few days -. You can see it now as an open issue on GitHub.

    Oh.. and as you can see, settings from v2 are migrated to v3 😉

    Smile,
    Juliette

    Done — thanks, Juliette!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘500 Server Error on Settings, icons not displaying’ is closed to new replies.